Having severe difficulties with intersect feature

I am highly frustrated. This is yet another variation of a recurrent problem I have with Sketchup: That it will not properly intersect faces and lines.

In the attached SKP file you will see a model that is properly drawn (“Screen Shot 2021-01-23 at 20.03.05.png”). I have been very careful that all Z-axis are at 1.5mm so everything should be “in plane”.

I wish to draw in a plane as indicated by the green plan in drawing “Screen Shot 2021-01-23 at 20.06.01”

I pull a rectangle at it forms as indicated in “Screen Shot 2021-01-23 at 20.04.16”.

The rectangle does not properly intersect with the other drawn edges (which it should do). So I then select everything (Ctrl+A) and perform an “Intersect” with the selected (and/or entire model) to force the intersections.

It works, but only partly. You can see that some faces intersected and some did not by the colorizations in detail “Screen Shot 2021-01-23 at 20.06.43”.

I have spent all day drawing and re-drawing to make everything perfect, but it just doesn’t work.

-I have rebuilt the model from scratch.

-I have exploded the group and done everything ungrouped.

-I was careful to only draw on the Untagged layer.

-I set my display to show dimensions to 5 decimal places to ensure that the plane would (should) exactly match and intersect.

My Sketchup version is indicated by Screen Shot 2021-01-23 at 20.08.08.

Help would be very greatly appreciated.

SU Intersect Probloem.zip (2.6 MB)

In future just put your images in the message window and attach the model as a .skp.
It would help if you corrected your forum profile as it is different to your screenshot, and we rely on the profile to help answer questions correctly.

Is this what you want.
2021-01-23 - TestBox.skp (123.8 KB)

Go to Model Info/Units and untick length snapping, it is know to cause inaccuracy.
It would help to work at a larger scale to avoid some of the tiny edge/face issues.

What you did was EXACTLY perfect.

What exactly did you do?

I followed your instruction and did turn off Model/Units/Length snapping. But when I drew in the rectangular plane and then did an “Intersect” I once again got the partly intersected model.

Did you do something additional in some way?

Your finished result was perfect. But I have not yet been able to reproduce it on my end…trying to understand so I learn.

This problem had plagued me for years. I am anxious to learn how to avoid/fix it.

I have not scaled up the model because I am doping 3d pricing and there is no easy/automatic way to scale down the STL file when exporting. It’s just such a hassle to scale up and down constantly. (Unless there is a better way.)


I took your “perfect” version and then just deleted the plane that was added, then drew the rectangle to form it, and once again the problem happened to me after doing an intersect. I cleared and then drew a connecting line so that the plane would auto-form and got the same partial results after an intersection.

I cannot reproduce the perfection that you did.

Am I doing something wrong or is there some other setting that is a problem?

I think there may be something more going on (with my settings?)

I took your (perfect) model and pasted it into my main model…it was still perfect.

I then went into the group and drew a circle (32 sides) that was 2.5mm in from the edge and centered as shown. Once again this disconnected plane appeared:

And here is the latest version of the model (with “Enable Length Snapping” turned off.) Drawing the line to close the plane did draw the plane, but then intersecting this surface with the model gave inconsistent intersections… (Model uploaded.)


2021-01-24 - Test3.skp (193.8 KB)

You can model in meters and export the model as mm by adjusting the export options.
.stl files are unit agnostic, so again you can export a 1m cube and if you tell your printer it is 1mm it will believe you.
Knowing what your printer imports is important.
Model a 1m cube and export it as mm, cm and m and see how you printer deals with each stl (incase you missed it there is an Options button on the export dialog that allows you to change settings)

You can of course easily scale up by 1000, then scale down at the end by .001
Or you can use the Dave Method.

Turning off length snapping will not fix your model, it is something you need to do before starting your model. It can cause tiny inaccuracies in the model that you will chase your tail trying to fix.

I repaired your earlier model with a couple of extensions, but they don’t work on the last one you uploaded.

Start fresh, open a blank model and set the units to no length snapping, save that as your default template.
Construct your model using m as mm, turn off the unit if you find it confusing.
See if that resolves the issues you are having.

I was playing with this model yesterday but wasn’t sure I understood the way you were creating the face you were having trouble with, so I didn’t want to post my own results.

Anyway, your length-snapping problem files provide an interesting testing ground for the Create Face command in the secret Utilities extension. Using Select-Loop in Quad Tools and Create Face fixes most of the problem areas.

I’m going to go back to some of my freehand drawing experiments and see if Create Face is just as helpful.

However, it didn’t work with the largest cut. Move-copying the Select Loop result revealed a superfluous edge.

Screen Shot 2021-01-25 at 8.23.02

There it is.

Select Loop also misses this edge, which has to be selected manually. After that, Create Face works.

Screen Shot 2021-01-25 at 8.23.38

Super confused by this Edge until I realized it was merely stranded outside the group.

Screen Shot 2021-01-25 at 8.24.40

Thanks for the help and comments.

What a shame that Sketchup doesn’t just work.

I can certainly start from scratch and build the model at 1000x. That will be a pain in other ways, as I exchange data with another PB Board CAD developer that uses SketchUp exported data for precise component placement. It’s a case of one fix creating two issues in a game of complexity just because of a buggy design.

This particular model has dozens of layers and many thousands of surfaces. So I hope that only this piece of the model needs rebuilding and then that it works. Otherwise…it is probably time to switch to a “real” CAD system that isn’t this buggy/cantankerous.

It just shouldn’t be this complicated to create a plane/surface. Really.

Turn off length snapping and draw it at at the original size and you’ll probably have no problems.
Otherwise feel free to use real software rather than this mickey mouse stuff.