Noob - Trouble drawing simple faces lol

Not sure why this is happening but I’m trying to freehand draw some irregular planes and as far as I can tell all of the lines are connecting, but they never form a face to where I can fill in a texture, they just stay an empty outline. Is there a setting somewhere that makes the line automatically detect and connect to another line? Maybe they are just sitting slightly above/below each other and not connecting. This is very frustrating.

Share the skp file so we can help you identify the problem.

Please also complete your profile with SketchUp version. That info helps us help you.

As @DaveR wrote, we can’t say for sure without seeing your skp file. But the two most common causes are edges that are not coplanar (all edges of a face must be in the same plane) and tiny gaps somewhere in the outline. A slightly less common problem is a small edge that protrudes into the outline.

Here is the shape and the .skp file.



jeffstone~.skp (5.6 MB)

Thank you. Is there a way to set the pencil to automatically snap lines together so that they are coplanar? or better yet is there a way to set the entire project to 2D? a plugin maybe?

I copied that shape out away from the rest of the model. If the edges were coplanar the Z-values would be the same. As you can see, they aren’t.

Best practice would be to start with a rectangle and draw the outline on it. Make sure to watch for On Face inference messages. No need for a plugin for this.

Also make sure you are using correct tag practice. ALL edges and faces are created and remain untagged. Only groups and components get tags.
Screenshot - 7_1_2022 , 8_12_43 PM

Another thing that is working against you is that you’ve moved the model axes off plane. Right click on an axis and click on Reset to fix it.

With things corrected…

jeffstone_.skp (3.5 MB)

Thanks for completing your profile but there is no SketchUp version 12.

This is the standard method of ensuring you keep on plane.

It makes me wonder whether it would be useful for SU to have a setting/command you could instigate that would make the whole of the default horizontal base plane (ie. the one coinciding with coordinates 0,0,0) a face that you can draw on, rather like a limitless piece of paper. It would make 2D work in SU easier I think. Musing.

Or perhaps a line tool mode that would lock one coordinate to a fixed value? It wouldn’t be terribly hard to write an extension to do that, but built-in would be better.

Been trying to cut it out of a rectangle, it honestly feels like a bug. I can hide everything else in the model, try to bisect a rectangle, and it just treats the new line as separate.

Yes someone please write an extension to temporarily disable the Z-axis! It would be so helpful to be able to do 2D plans in this model without constantly slipping out of plane. You could then toggle on the Z-axis to extrude.

This sounds like a context issue. Perhaps you are not drawing the edge in the same context as the rectangle. If the rectangle is a group or component then you will need to open it for editing before your edge has any effect.

There are various issues with your model, but basically it just isn’t flat to begin with.
You have things extending out all over the place, even a semicircle poking out at right angles underneath.
But this is the part you were asking about, it isn’t just slightly not flat, it is visually not flat. Certainly not a bug issue.
Not flat

You have profiles, back edges and depth cue turned on which makes everything difficult to see. Turn them off and have a look at some of your edges and you can see whats going on. I haven’t even mentioned reversed faces or incorrect tagging.

If it were a bug, you would see lots of references to it on the forum.

Thing is, SU is a 3D program and was not really intended for 2D drawing. So, although you can (and many of us do) use it for 2D drawing, you have to learn how to do it effectively. As you can tell from all the comments so far, you haven’t reached that point quite yet.

Thanks for the feedback everyone. Some responses:

  1. Yes I know my elevations are all over the place. The reason I have different groups higher/lower than others is because whenever I have two intersecting faces, the textures blur together, so if I want one “on top” of the other one I’ll just move it up an inch or two. Is there a way I can keep everything snapped to the ground, yet still be able to decide which face sits on top?

  2. I’ve tried so many times to draw a rectangle and cut the shape out of it. The rectangle will immediatley form a face, and even when I group it and work in edit mode on that group, the new shape will not be recognized. In other words SU will treat the new shape as separate from the rectangle. I tried doing this in the video but now I’m having trouble even drawing a rectangle.

  3. Beginning of video 1: Why is it trying to draw rectangles at a diagonal once I’m in the middle of the model? It will do a normal rectangle if I start at the axes intersection. Even when I use the directional buttons it does not let me draw a rectangle that’s parallel to the axes. I’ve never had this problem until working on this particular project.

  4. Hiding everything in the model and trying to trace the shape I want, it does not create a face. I know my arcs are sloppy but I just wanted to make a quick demonstration.

  5. Second video - In edit mode, the lines I draw are not all on the same plane. Why is this happening?

  6. I turned off back edges, profiles, and depth cue after making this vid and tried it all again. Same results.

Video 1
Video 2

Can you say more about reversed faces and incorrect tagging? What am I doing wrong, and is that affecting my ability to draw a shape on a single plane?

It appears you glossed right over my post.

Tags do not provide separation between raw geometry. You must use groups and/or components to do that. turning off the visibility of a tag applied to groups/components will hide those objects even though the geometry inside is untagged.

Leaving the geometry untagged makes the workflow easier with less chance or errors as you have in your model. With Untagged always left active and all edges and faces untagged, you don’t need to even worry about what tag is on the objects when you are editing them. No chasing active tags like you have to chase active layers in other programs.

See:

In all reality you need to spend time at The Learning Center to gain knowledge on how SketchUp works. Next, go to The SketchUp YouTube Channel and study the Square One series. Both are sponsored by the SketchUp Crew and are well worth the time spent there. Time spent at these sites will save much frustration on your part and speed up your modeling.

1 Like

Oh I see. I’ve been doing my workflow backwards: Create a shape > select it > tag it > group it. I should be grouping before I tag, correct?

Yes you should be. And periodically check the geometry in Entity Info to make sure you are keeping the edges and faces untagged.

1 Like

Hi @3totheD,

Because I have chickens and rabbits ;^), here are some things I see.

Not flat:

Others have pointed this out, but the geometry in your basemap is not flat. There is something, a component, “triangle bed”, jutting down and many of your other components are not ‘at zero’ elevation. Don’t think in terms of ‘layers’ and what sits on top (yet).

You may be merging ungrouped geometry when trying to model off of zero elevation. For example, these vertical sections that are being created are grizzly (difficult to deal with):

Your group “symbols” consists of components.

This looks like a sort of ‘pallet’ that you are working from. They are in your components window, so they don’t need to be in your model (not a bad idea, just making things less clear for now).

I drew a line, 10ft straight down from the axes that was going to be used as the corner of a rectangle for a new 2D Basemap. It shows a problem:

It is way too thick. Go to styles, edit:

Turn off, Depth cue, Profiles, and Back Edges:

The line I added and all of your lines are now much easier to see (they aren’t too thick):

Try something like this:

1 Like