Faces not connecting

Hey all, just a precursor, I am fairly new to sketchup and 3D modeling as a whole.

What I am trying to do is create faces from a CAD generated dxf file. So far I have had no issues with doing this, however recently I came across a few scenarios where the faces will not draw.

Since they will not draw, I have used the contours tool to create TINs to attempt to figure out the issue. Unfortunately I need faces for what I am trying to accomplish and I cannot use the TINs.

Here is one scenario I ran into (I would attach multiple pictures but am not allowed):

My theory is that the face will not draw because the surface is not flat due to that one edge, but I cannot understand why the TIN would not draw properly.

If anyone knows how to either add a face to the mesh or why I am running in to this issue, please let me know. Any and all help is greatly appreciated.


Any chance that you could share a file? Without it we can guess or throw ideas at you, but sharing the file will assure a more accurate answer and more helpful replies.

If you can upload the skp file that would let us give a definite answer. Have you tried turning on View->Hidden Geometry ? It’s not definite from your image, but it looks like the front of that object is not planar, like there is a flap hanging out into space.

Yes it does look like the edge is hanging out like so:

I am just curious if this is an issue with the DXF or if it has something to do with sketchup.

Here is the file:

Test3.skp (84.3 KB)

For sure that corner is caterwonkered in the skp! Can you also upload the original dxf so we can try to see whether the issue arose before or during import?

DXF Test.dxf (86.4 KB)

Here you go, thanks for the help by the way, it is also nice to know I was on the right track.

As best I can see, the problem exists in the original dxf:

So what do you think is the problem? The lines are connected and I am able to join them in the DXF.

I know the face will not draw because the line is not flat (that edge has a different angle than the rest, atleast that is how it seems) but I cannot seem to understand why the TIN would not properly draw.

Sorry, I can’t answer that as I am not an AutoCAD user. I just brought up the dxf in a viewer and noticed that the same misaligned corner already exists before import to SketchUp. Maybe @Anssi can guide you (I believe he’s knowledgeable about AutoCAD).

What dimension unit does the DXF use? Your import unit should be set to the same unit as used in the DXF. The whole thing is about 25 units long, so the basic problem might be that the thing will be very small if you import it in millimeters. I used meters, and had no problems adding faces to the model either by redrawing edges or with the Sandbox from Contours tool. As stated previously in this thread, two of the line loops are not coplanar, and to fill them you will have to add diagonal edges.

This thing is so simple that you would get better results by modelling the thing directly in SketchUp from scratch. And, first of all, I would recommend creating the model parallel to the SketchUp axes and not oddly skewed as the DXF.

Taylor2.skp (87.8 KB)
Taylor1.skp (85.1 KB)

Both the DXF and sketchup are in inches. The model that I have is a smaller portion of a much larger house (the rest of the house did not have issues which is why I did not include it).

Also the direction the house is facing is important to what I am doing, which is why I did not model it on the axes in sketchup.

Do you think there would be another solution to dealing with edges like these or should I just import the DXF files with a larger unit like meters?

I appreciate your help.

I have run in to another scenario, however it is even more puzzling than the last. (I will try to include pictures, however I do not know if I am limited or not).

This is the entire house that I am working with.

As you can see, I was able to draw faces on certain roofs.

The reason the roofs will not draw is from my understanding the weird corner connecting the roofs. However the right roof is completely square. If I draw a line connecting the two corners of the roof, the face will generate, and when I delete that line, the face should still be there, however it disappears.

I attempted to redraw the entire house in CAD. Even after redrawing it, I still got the same errors.

I was only able to get it to work by removing the weird corner and the right roof, and mirroring the left roof and just redrawing the edge.

I am now lead to believe this is a sketchup error, I do not see why I would be unable to draw a face on a completely flat square.

If anyone has any insight in to this problem please let me know. I have attached both the DXF files (DXFTest1 is the original file, DXFTest2 is the one I redrew.

DXFTest1.dxf (5.0 KB)
DXFTest2.dxf (93.0 KB)

RoofTest.skp (86.4 KB)


Your test that drawing a diagonal created faces but deleting the diagonal eliminated them proves that the four corners of that “square” are not coplanar to within SketchUp’s tolerance. Have a look at the screenshot below. The corners do not have the same z values; the “square” is twisted.

True, I guess the problem lies within the DXF files since I had to redraw them to get them to work.


There seems to be very little about these roof planes that are square or flat. You can sight along the edges from the side and quickly determine by inspection that they are not coplanar.

I would suggest building up the roof from faces rather than edges; that is, start with a face inclined at the appropriate angles for each roof section and cut pieces away from it. Try keeping each roof plane separately grouped until you can see that the sections fit at all the corners.


I have to ask why you are creating the model in CAD and then importing to SketchUp? Is there a much more complicated pre-existing CAD model of which you are just showing fragments that illustrate the issues? What you have shown us here so far would be pretty easy to create directly in SketchUp without the out-of-plane issues you are seeing.

I am only given the DXF files, I don’t make them, they are needed in CAD by other people that I work with which is why they are not simply done in sketchup.

Valid reason!

If You use the WORKPLANE-plugin You will find the wrong angles.

roof.skp (87.6 KB)

I checked the alignment of the geometry in question by this method:

  1. Rotate the model until the bottom line of the geometry that won’t make a face is on the green axis and the adjacent bottom line is on the red axis.

  2. Draw a line from the top most corner of the geometry that won’t make a face on the green axis
    until it lines up with the end of the bottom line then down to the bottom line. This should make a face and reveal the mis-aligned geometry.