DXF push/pull problem

Hello to the highly esteemd SU folks out there. Has been a while but I have had some success. But today I created a logo with a key in it for a sign, and saved it as a DXF. Can’t seem to push/pull thetters or the key … is there a way to do it? THANKYOU!

it hard to tell without looking at the file, but it is likely one of the following reasons:

Those are lines and not surfaces.
The geometry is in a group/component.
The geometry is not flat.

Aaron, This is the skp file, can you take a glance at it and see what’s wrong? I thought I was getting better at ythis but there is SO much to learn.>>>>>>>>>link to the file>>>>>>>>https://app.box.com/s/0zlyss7m3qdnh3x96u4nd9ir6jns9trd

It’s hard to tell without access to the model but in case the problem is that there are no faces at all you can try this plugin.

If there are problems with edges not connecting properly ThomThom’s Edge Tools could be helpful.

here is the file (model)…I also posted it above. thankyou for your interest.https://app.box.com/s/0zlyss7m3qdnh3x96u4nd9ir6jns9trd

The file was posted while I was writing my previous comment.

I’ve looked at the model and the text isn’t drawn onto the face. However, even when moving the text down onto the face the face isn’t split by the edges. Sometimes Sketchup doesn’t seem to want to create interior holes in existing faces. However I manage to get around it by selecting everything not connected to the box (Ctrl+A followed by Ctrl+Shift+Triple click the box), grouping it, exploding the group and repeating this process until everything is connected.

Please re-post the faulty link as say…


Unfortunately, I am not good enough to use plugins just yet…Hopefully a workaround?

The problem is that you have a bunch of lines floating above an extruded rectangle

One solution is to draw a rectangle on the same plane as the lines, then select it all and right click and choose Intersect Faces - With Selected:

Than you can Push/Pull letters to your heart’s content!



Seems to work great on solid letters, bugt if I try the “e” of rent, or the key, the details won’t push/pull…Is it possible to make a componant of the keychain and all the letters and push/pull them at the same time? Thankyou for your help.

If you change your Style (Window - Style) to a default style, you will be able to see that some shapes did not intersect:

All you need to do is zoom in on those sections with dark lines, and trace over an edge. Then it will break the plane and allow you to PP them.



You should also keep all geometry on Layer0.

You may run into issues in the future as you have your lines on layer color#0e0e10ff


A big THANK YOU to the experts at Sketchup, for helping me solve my extrusion issue. I am very happy with the insightful answers and the interest with which they offer their solutions. You guys and Gals are GREAT!

Almost there! I have been practicing with the push pull option and tried “dialing in” say, 1" on each letter. For some unknown reason, there seems to be a failure on some of the letters. Is there a way to extrude each letter to a particular height? Here is an illustration of what I am encountering…And I am thankful for your interest in helping me with the best 3D application ever.> > > >

Here is a better illustration…The four rectangles on the top were all told to come up 1 inch (individually), but when I got to the 4th one, it has a mind of it’s own, frustrating, but I am sure it’s user error. It would be nice to do a batch of letters and push pull them at the same time. Thanks for looking! > > > >

you can enter an exact height by pulling up, then typing the height and hitting Enter.

Alternatively, once you have pulled one surface, if you double click on another, it will pull the exact same distance.

You got to REALLY ZOOM IN to the letter e . . Some lines do not connect so it is not a complete area to Push Pull . . I had same problems in my small letters . . Also in letter a and a few others . . Got this from a message long ago from one of the blog people ! … So just passing it along . .

You can select them all and use the plugin “Joint push pull” from Fredo 6 for all selected faces.

Without a plugin, you can try to not pushpull the faces of the letters but the face around them, depending on the letters it may be the faster way.

Thankyou Lynn, Aaron, and Cotty…I thiink I’d lie to try the plugin, but this will be my first plugin in SU. Is it in the extension warehouse? Yours, RoB

Hi Aaron, I had already tried partially pulling the letters up and then typing “1 in.” in the measurements box. Some of them do go to 1" and some do not. Can’t figure that out. Thankyou.