Push pull not working on my dfx file... HELP! Please


#1

Hi All,

Sorry if this has been solved before but I cant find the answer. I have a dfx file that I want to use push/pull on but it isn’t working. The file is ok I believe as I sent it to a laser cutter firm and they looked at it without comment.

When I go to use the tool, I click on the face but it does nothing. If I move the cursor onto an edge the tool icon has a red circle with a stroke through it. I saw someone advise to change the checkbox in preferences to “disable pre pick on push/pull tool” but this hasn’t worked either.

I am wondering if there is something about the file that is incorrect though. Would some kind soul let me send them the file and see if they can use the tool on it? It would be much appreciated. I am new to Sketchup but despite my research, this isn’t working.

Kind Regards,
Simon.


#2

Sounds like you need to double click to open the group for editing before using pushpull.


#3

Is the model section you are trying to push pull inside a group or component, when you import dxf into SketchUp the geometry is always wrapped inside a group. You can also only push/pull a single face, not the whole file. Maybe if you post some images me or somebody else will be able to help.


#4

thanks so much. Should I select the tool then double click, or double click and then select tool.?


#5

Thank you for your help. The file consists of a single face only. Its very, very simple.

I quickly created another file and used the tool ok, but when I go to use it on my dfx it wont do anything.

Would you mind telling me how to post an image with my response?


#6

When you select reply you use this button:
50


#7

Got it! Here is a screen shot of my file, I am not sure if this is of any use but here goes.


#8

It has no face, trace one edge and a face should appear for you to pushpull.


#9

thanks!


#10

Ok so it looks like you only have paths drawn not a solid face. You can only use the Push/Pull tool on a solid face.

You will have to open the group by double clicking and then trace some of those lines in order to create a face.

Edit: what Box said


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.