PUSH/PULL not working

Hi There,

Push/Pull toll not working.

I opened a brand new project and tried pulling and it worked.

If someone could help me out that would be great.


In SketchUp, right?

Do you hope you can use the PushPull (from SketchUp) in Layout?

I uploaded wrong file, just tried to upload sketch up file but it was to bit, it’s 30mb, any ideas how to upload a file?

You can try to see if you can reduce the file size:
Window > Model Info > Statistics > Purge Unused, then Save.

Otherwise, there are file sharing services, you can use one of them: Google Drive, Dropbox, wetransfer, etc…

The push/pull tool operates on single faces. Either there is no face to pull, or you are trying to use the tool on a “surface” that is, multiple faces with the edges between them smoothed.

That worked, file size is much smaller.

I have attached file.

Would be great if you could help.



Floor plan with kitchen island 180520.skp (402.5 KB)

I thought that might be it, I checked to make sure they were on the same plane, they looks to be, I have attached the file, maybe you could have a look for me.



When I opened your file the face style was set to Wireframe so there’d be no faces displayed for Push/Pull to work on.
Screenshot - 5_18_2020 , 5_07_16 PM

Changing the Face style to Monochrome displace faces but also makes it evident there are no faces where you would expect them for some of the wall outlines. You can see the dotted blue axis line through them.

You need faces for Push/Pull to work on. Typically the lack of faces is either due to gaps in the loop of edges or edges that are not coplanar.

And sometimes it’s a little tiny edge segment left from sloppy modeling or bad CAD import which was the problem here near the cursor.

Screenshot - 5_18_2020 , 5_14_45 PM

Erasing it allows the face to be completed and gives something for Push/Pull to do.