The Push/Pull function doesn't work in my model

Hi!

Please see the attached file.

I created the outline of the parts then I made it into a group. They are mirror images of each other for Left and Right,

I then opened one group for editing and tried to use the Push/Pull funtion to extrude it 50mm.
The function does nothing.
It behaves as if there is no surface to pull out, but no message of any kind is displayed.
If I use the Plugins/Cleanup/Erase stray edges function, both my parts disappear.
As far as I can tell from visual inspection at high enlargement, there are no gaps in the outline, and all the edges lie in the same plane.
The problem is probably due to something I am doing wrong, but I have no idea what it is.
I exploded the group and tried again to Pull it out, with no change in behaviour.
The same applies to the 2nd group.
I am using SU2014 Make (not Pro) on a Windows 10 desktop with Intel i5 processor, 16GB DRAM and 2TB of hard disk, and one 21" display.
Any help will be greatly appreciated.

Hylton

Plastic Feet.skp (71.6 KB)

You have the model set to Wireframe and not shaded. Also, you have deleted the original faces. Change to one of the shaded face styles, and redraw one of the edges to make the face fill in again.

You’re also working in Parallel Projection, which shouldn’t affect push pull, but does sometimes make it hard to manipulate things in 3D.

To elaborate slightly on what @colin posted, the pushpull tool works only on faces. In wireframe mode, there are no faces, only edges, so there is nothing pushpull can use.

In addition to the info you’ve already been given I’ll add that you should get in the habit of keeping your model close to the origin. As it is your tiny little groups are a long way from the origin.

Hi Colin and @slbaumgartner,

Many thanks for your fast reply.

Coming from a background of learning mechanical drafting long before CAD systems were available, the old way, with (mechanical) pencils, ruler, protractor, compass, and erasers, etc., I am not very comfortable with drawing in orthogonal projections. I am most comfortable with the parallel projection in plan view. This is why my model is in this mode. For 3D objects we drew them in plan, side and front views, all in parallel projection.

I am aware that pushing or pulling in plan view is a problem, so before I do this I use Orbit to get a view suitable for using Push/Pull. I did this in another model and it worked fine.

As for deleting the original face, how would I have done that? I didn’t do it deliberately. Could it be that, because I was in Wireframe mode, even simple closed shapes like circles or rectangles are created without a face. I used a combination of these to construct my parts.

And thanks again for your help. Your solution worked perfectly.

Hylton Brenner

That may be but SketchUp was designed to be used in Perspective with Parallel Projection used for output. As long as you are aware of the potential pitfalls of modeling with the camera set to Parallel Projection, though, go for it.

No. Working in the wire frame face style does not prevent the formation of faces. It only prevents them from being displayed or acted upon by the various tools such as Push/Pull.

1 Like