Push/pull - cannot generate face

I have created a drawing which I want to pull into 3D. I’ve tried making it coplanar with Fredoscale but for the life of me I still cannot get SketchUp to see this as a face. I know I’m doing something wrong, but would appreciate any help. I have attached the file and look forward to any feedback. Thanks
wheel1.skp (596.6 KB)

There’s a gap in the edges just above my cursor in this screen shot.

Do you want to use Push/Pull or are you using Follow Me with a circle to make a wheel?

There’s a second gap on the opposite side as well.

1 Like

thanks for coming back so quickly. I want to use push/pull - so to extend the plane up into 3d then to hollow it to a shell. It will be an electronics casing for a motorsport steering wheel. Do I just need to delete the line(s) and replace them? Thanks

Deleting the long straight edges and redrawing them as single edges would be good. It would also make for less cleanup.

I would suggest you keep your model close to the origin. Leverage the axes to help you with your modeling.

that’s worked. Perfect. Thanks!!