Issues with face creating from dxf file

Ive imported a dxf file that Im creating faces using make faces plug-in. It mostly works fine but on the sidewalk line work it doesn’t work, but if I draw a line across the sidewalk a partial face is created. I have to keep doing this all the way down the entire length. Is there a way to figure out what in the geometry is causing this?

Gaps are a typical problem in imported CAD files. I would draw a rectangle that is larger than the imported DXF geometry. Select all and run Intersect Faces. Edit the style so Profiles are set to 2. Look for heavy black edges in the imported geometry. If you’ve got a gap, you’ll narrow down where it is.

Ive tried what you suggested and have adjusted the profile lines to 2, but I dont see gaps I see the bold profile lines and gaps where the lines are at a thinner weight. Are the thinner lines the issue? Should I erase these and re-draw them to solve the issue?

The thinner edges indicate that they are forming closed loops and dividing the larger surface into outer and inner regions. To see what I mean, open a new file, set Profiles to 2 and then draw a rectangle. Use the Line tool to draw a shape in the middle of that rectangle. You’ll see that until you close the loop, the edges you are drawing show as profile edges. when you close the loop, the edges will switch to thin, non-profile edges.

Another not uncommon issue is that the edges from the DXF file are not co-planar. SketchUp has no tolerance for non-coplanar edges. You can check this by setting Precision high and placing leader text at endpoints to get coordinates at the ends of the heavy profile edges. If the Z value varies from point to point, you won’t be able to have a face. I made a quick example to demonstrate.

I guess what Im asking is if lets say its not a coplanar issue what are the solutions? To trace from where the bold profile lines stop in order to complete the loop?

Did you try that? Did it help?

I did draw the rectangle and intersect faces. Haven’t tried the header text solution to z levels.

Ive copied and placed the isolated layer. The problem area is the south-west block in the file. Is there a way you could look at it. Ive tried the intersected layer move and could see the different weights but couldn’t create the face. Could you look at it if you have time? Ivw got the file down to 6.5 mb. How do I get it small enough to send?

See if it will Zip compress to less than 3MB. If not, upload it to the 3D warehouse, Dropbox, OneDrive or a similar file sharing site, and post a sharing link here.

I sent you a PM a few hours ago. Haven’t seen your file.

This topic was automatically closed after 91 days. New replies are no longer allowed.