Problem getting rectangle to intersect face

https://sjc1.discourse-cdn.com/sketchup/uploads/default/original/3X/5/9/59f65217ffa2255c8a16bfc48f4c246dbd98e726.mp4 Hi , I have used SU for a fair while

I still have frustration with this seemingly simple task of making co-planar geometry

Im just trying to draw on existing faces and push pull to create openings, in simplified building model , for purpose of 3d printing.

One reason why its difficult with this model is that there are some walls off axis

and im trying to trace of other layer that may have slight differences in wall position

Usually i will persist with a variety of methods, and get there

some ways to fix-

retrace line by line

draw rectangle

draw triangle all over the place

try to see if line not quite on face by zooming in then try to draw perpendicular toward face

align axis with bit i’m working on

intersect with selection or model

draw face purposely away from wall then push right through / then intersect

drape onto face

weld plugin

I should try solid tools more often

in this case at the moment i feel i have to start again with some walls ,that were drawn off-axis.

Intersect with model is not working for me now as other geometry on other layer / group

Maybe best separate into groups at start of project with each group aligned to on axis.

Then make hole, then join group together.

I do have lots of plug-in in my armory from the wonderful developers on these forum !!, there may well be some great solutions out there, Until I used this forum i never new why some lines are thinker than others !!! (thin lines intersect face - whereas thick do not)

cheers

Ben

HI. Upload the model and maybe color a wall that you want to make an opening in. Maybe someone can spot what is making it difficult.

2 Likes

hi , I forgot to colour it , but you can see some small windows im try to punch through on off-axis wall, video may show ones i had trouble with. cheersface test.skp (185.6 KB)

First thing, turn on the axis in the view menu, then rotate the whole model so it has the solid blue axis up and change the camera to perspective. Then go to work. I deleted your missing windows and had no trouble redoing them with the rectangle tool.

2 Likes

A couple of suggestions that aren’t specific answers to your issue but might be contributing factors and will help your modeling in general:

  • Orient the model so that the blue axis is up, that is, so that the red-green plane is the ground plane of the model. SketchUp has a notion of “gravity” that tries to keep the horizon level across the screen. Drawing the way you have done can cause orbit to behave strangely.
  • Use perspective projection while drawing. Save parallel for orthographic views of the final model if required.

@Box posted the same advice while I was typing. Like him, after doing those things I had no trouble redrawing the windows and then push-pulling them through. Elsewhere in the model there are some openings that may cause problems because they exactly fall on or overlap a wall edge on the opposite face. And one of the tall narrow windows was already pushed halfway through, which interferes with completing it cleanly.

1 Like

thanks for reply’s people,
Very interesting that no problematic geometry found
took me a while to fix windows on one wall

Also interesting to me that you both use Perspective
Why is this better than using parallel camera ?

I understand that i had a random axis rotation and will make sure blue is Z in future, sometime i just align it which ever way I think is aligned without keeping blue up, and this makes navigation issue as you said.

cheers Ben

Parallel projection is an artificial view that intentionally distorts the model. In some situations this is either desirable or required by the recipient. But it is far more likely to cause clipping issues and difficulties picking things that perspective.

1 Like

Thanks Slbaumgartner, I find parallel easier to navigate , especially 3d orbit.
Also easier to see which lines are parallel,
I will give perspective a try, cheers Ben

Keeping solid blue up will help with that.

1 Like

Look away from your screen, now through your nearby window pane.
Pick up a marker, not just an ordinary one but a permanent marker.
Draw over what you see outside (parking lot, some building across the street, horizon, etc.) on that window pane. Most real life parallel lines outside will not even be close to being parallel on the window pane. Consider the pane to be your screen.

Sorry for the mess you, oops we just created.

(I wonder how people find it easier to model 3D models in ‘Parallel Projection’ model.)

6 Likes

Maybe it’s a matter of personal perception or the mouse settings… I too cannot stand trying to navigate or view in parallel projection for long. It looks cool in some presentations of course.

2 Likes

I create and edit my models almost exclusively in parallel projection (more traditionally termed “axonometric”) because dimensional relationships at the front and rear of an assembly appear the same. Perhaps this is because for most of my career, I created construction documents manually: pencil, paper, parallel bar and triangles. My eye is trained to interpret an axonometric projection on the two-dimensional surface (either paper or computer monitor). That said, I use perspective projection (one-, two- and three-point) for presentation, and to verify that the model is pleasing. I am ecstatic that computers have enabled a rapid perspective projection to verify design solutions. Even a quick freehand perspective sketch isn’t as rapid, editable, or, or, or …
Of all the 3D programs I’ve used, only SketchUp has problems with the clipping plane while moving around the model in parallel projection mode. My opinion is that this is a flaw in SketchUp design, I will put up with clipping plane issues, and grump and moan about it (to myself), because working in parallel projection is just easier to see dimensional relationships, geometric conflicts, and is WAY easier to spot tiny errors that sometimes occur in large assemblies. My opinion is that is more accurate, and accuracy, for me, is the primary reason to use any CAD software.

Any advantage in working in perspective and FOV angle 1.00 degree when clipping is an issue? I’m not sure if it helps at all but 1.00 degree perspective pretty much looks like parallel projection.

And ‘Position Camera’ only works in perspective mode, not in parallel mode. If needed.

1 Like

What the image on the screen LOOKS like isn’t the same as what it truly is. If I’m modeling a building exterior, with landscaping, sun shadows, background image, etc, I will do so almost exclusively in perspective mode.

But when I’m creating a machine part, or trying to figure out why a molding doesn’t sit on the wall correctly, I could care less about the camera position, or walk about, or the “eye” thingy. I use orbit, and I zoom in, and rotate the model until I locate the error. And I find that using parallel projection is the fastest way to identify such issues without error. In such cases, “getting close” is inadequate.

I have tried using perspective mode to navigate, then switch to parallel to work on some detail or other … but the FOV is never close, and I still have to zoom out/in to get to that point in the model where the issue is.

1 Like

pbacot - Did you mean perspective ?
Tpdes-
I totally agree with you , I have no idea how people can deal with drawing in perspective
Parallel all the way for me - except for rendering

The question is - does the camera setup, whether parallel or perspective , in any way effect SketchUp’s ability to detect when to draw on a face ?

cheers for reply’s

Short answer: no.

No. For me perspective is easier / faster to use when modeling.

For the ones who like to model in parallel view, one might consider this approach: instead of using the scroll wheel for zooming or ‘getting closer’ switching to a standard view and scrolling could improve performance ( have not tested, though)

“Standard” views are limited to top, front, right, left, and back, plus one axonometric (parallel) view that approximates isometric. Frequently, I swing the view around to look for errors where geometry deviates from the UCS planes, or are hidden in isometric view. Frequently, I need to look at the underside of something. Why can’t we have a bottom view???

When working in perspective, to scroll to zoom, one must have the cursor on the geometry, somewhere. It is thoroughly impractical to scroll zoom if the cursor is on blank space (in perspective projection). In parallel projection, the scroll zoom functions the same regardless of where the cursor is. Really, people, the only issue I have with editing in parallel projection is the clipping plane issue. To restore the portions of the model that are clipped, one must zoom to extents, then zoom in again. This works for awhile, but soon, the clipping plane reappears. But this is the same old rant, and obviously no one at Trimble is terribly excited about changing it, so I’ll just shut up.

It’s a bit off topic but bottom view is available from the camera menu, no toolbar button for some reason though.
See this thread