Bug with intersect face?

Hello, I am currently in the process of establishing a company store and I am interested in incorporating additional features. One specific requirement is to include a bookshelf, which necessitates recalculating the overall area. However, when attempting to execute the “intersect face” command, an issue arises.
With this configuration

Thanks for your answers

Share the SketchUp model file so we can see what you are working with.

What version of SketchUp are you actually using? Your profile doesn’t seem to match with your screenshot.
What operating system? 2023 is not an answer to that question.

Sorry I was in rush, it’s Windows 10.
Here is my SKP:
Sketchup test.skp (78.0 KB)

And here is the version

Please correct your forum profile. SketchUp Pro is not the “Free Plan”.

Done :white_check_mark:

@colin might have an explanation for the oddity with Intersect Faces. I suspect this is the “bowtie issue”.

Screenshot - 6_12_2023 , 11_48_04 AM

Thanks for updating your profile. When it’s correct it helps us help you. When it’s bogues it doesn’t help anyone.

It’s curious.
It’s not just creating lines at the points of intersection (like it should), but seems to be creating all new geometry.

I tried to recreate the error using only one of the blocks, and didn’t seem to have any issues.

However, when I tried a grouping of the blocks, That’s when things when bananas.

This is what’s left after the original groups are deleted. Not only did it create faces at the intersect points, but also made whole new outlines for the blocks.
I’ve never seen anything like this. I suppose a temporary workaround would be to explode the blocks, making them into a single shape, and then intersecting that way.

It’s got to be something to do with the overlapping geometry of the groups.

Sometimes it creates the good geometry, sometimes it’s doesn’t. Sometimes it doesn’t work on a single block, sometimes it does.I’m completely lost

I agree with @DaveR that this smells like a variation of the longstanding “bow-tie” bug in which an inner loop folds back over itself and confuses SketchUp’s understanding of what is a hole vs an inset face. There is lore about what sorts of drawing actions trigger a bow-tie and how to avoid them. But, so far as I know, despite years of knowing it happens, the developers have never implemented a fix and have never offered an explanation of why it can’t be fixed. Here we have the added complication that it is being created by the intersect operation, and a user has no insight into how that operation is implemented.

For a test, I brought the file into the browser-based version, and whatever this is seems to be there too, though overall behaving a little different.

When I tried intersecting with a single block, all I got were those two lines below the first test. As for that grouping, the extra geometry is all there, but the push/pull effect in the original model isn’t there and I can’t seem to replicate that part of the error.
Finally, for a laugh, I exploded the group of blocks into their raw geometry and intersected from there.

Behold the bowtie.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.