Gray and black lines

Just started using SketchUp 2020 and notice that some of the lines on my drawings appear to be grey - seems arbitrary.

Any ideas?

This is a very visual medium, so images help.
At a guess you are seeing the difference between edges and profiles. Edges cut through a face profile border the edge of a face or shape.

Hi Box,

Many thanks.

Only lines in the drawing.

In my previous version of SU all the lines on this drawing were black.

I don’t understand your reply.

Sorry. Struggling to explain.

My drawing does not contain any groups or components, just lines with no areas of any colour.

I though that all lines on the same plane would be black as was the case in my Sketchup 2016.

Box has asked you twice to share images that show what you are seeing.

Maybe it’s a setting you can change. Maybe you need to upgrade the graphics drivers for your old GPU. Without being able to see what it is you are seeing, we can only guess. Guessing is a waste of your time and ours.

Sorry, new to this. How do I attach a jpeg to a reply please?

Just drag it in and drop it.

Understand.

Does this help?

Looks like profile and non-profile edges (like Box suggested in his first reply) with the non-profile edges being thin enough they don’t show as black as the profile edges.

What width do you have the profile edges set to? Can you share the .skp?

PROPOSED 2D SECTION A-A OPTION SIX - CONSTRUCTION - B REGS FEB 2020 - THREE.skp (2.0 MB)

Thanks Dave

So the profile edges are set to 1; the same size as normal edges. In some places you have faces painted black and others you have multiple parallel edges close together that when zoomed out will read as single, heavy lines.

On a different note, It’s not really a good idea to set the back face color to match the front face.

Many of those dark lines are places where you have multiple edges very close together and they create that impression on the display. Some others are faces you have painted a dark color.

thick

2 Likes

Thanks

So leave the profiles set to 1 and change the back face colour.

Just felt it odd that all the lines on my last version of SketchuUp were uniformly black.

I’ve installed SU on a new PC with a better graphics card than before.

Yes, unless you want to show profile edges as thicker than other edges.

Generally it isn’t a good idea to leave back faces exposed. If you have set your style so they are the same color as the front faces, it’s difficult to figure out if you have faces that need to be corrected. I use a green for the back face color in my styles that I’d never intentionally use in my modeling so I can quickly and easily figure out when I have exposed back faces.

Still an Nvidia GPU? It wouldn’t hurt to check to make sure graphics drivers are up to date. It’s unlikely they were when you first started the new computer. Also please update your profile with the correct info.

The appearance of the model can be affected by how SketchUp deals with display resolution. If the new computer has different display than the old one, that could do it.

Thanks Dave,

Will do.

All the lines became uniformly black when I set multisample anti-aliasing to 0.

That might be okay for fast modeling, but for presentation you’ll likely want to have the best anti-aliasing you can set.

That’s a bit like finding the sharp pencil drawing isn’t right so you draw over it with a crayon.

I have much to learn.

I’ll check the graphics card.