Antialising in SU 2017


#1

What happened whit the looks of SU2017?!?!
There is almost no difference between profiles and edges in thickness. But the major problem is the lines themself. They look intermitted, antialising not working. It hurts my eyes to work like this. Can anybody help with this issue?


#2

AA is controlled by the graphics card. Try updating the graphics drivers and make sure SketchUp is using it and not the on board Intel GPU if there is one


#3

The GPU listed in your profile should support anti-aliasing. Could you check under Window > Preferences in the OpenGL Panel whether anti-aliasing is enabled, please. What level of anti-aliasing are you using?

Cheers,
Dominic


#4

Still, not good as it was in SU2016, the edges are just too thick and still not perfectly AA. It’s annoying as hell


#5

Could you upload a .skp file in which the issue happens?
I like to see if I suffer from the same issue.

My graphics card is a Geforce GTX 750 Ti 2G OC
And my anti-aliasing is configured x4 but I think it supports x16 because it’s on the list.

What I noticed in my case it’s that certain lines looks of a same object looks thiner depending on the zoom level.

Not sure if with modifyng these settings you can get the result you want.
settings


#6

Do you still have SU2016 installed? Did you have Hardware Acceleration enabled or disabled?


#7

I guess it’s not the same issue as yours, @modeliranje3d , but this is what it happens to me depending on the zoom the inner circle has a part thiner.

example


#8

its useless I upload my file since it happens with all my .skp files opened with SU2017. My edges styles are exactly like yours. I could set Profiles to 3, and than I would get at least a difference in thickness between edges and profiles, but for a vectors program it would be annoying working with these thick lines.
Never had these problems with older versions of SU. It’ just confusing and plain ugly looking.
I notice from your uploaded images that you have the same issue, you don’t see it? Seems to me it’s just the way sketchup looks now? If only we could change the edges thickness like we can do with profiles, I believe it could resolve this issue.


#9

I don’t have 2016 installed any more.
Im posting another screenshot. Does this look ok to you? To me it looks awful. I really hope that there is something wrong with my settings and that this is not the way 2017 looks now… The AA is not existing.


#10

Your screen shot is a little small to be able to see it well. Can you upload the SKP file?


#11

DaveR, do you not read my posts? There is nothing wrong with the file itself. The problem is the way Sketchup looks. So any file on my pc with my graphics card looks like this, and it looked normal in older version.
I found a thread (SketchUp 2017 Resolution) that “explains” this problem but I can’t believe that there is nothing I can do. Sketchup was supposed to be a userfriendly program and should be able to run on “weaker” graphic cards as well as on the monster ones. I’m using Autocad 2017 and if Autocad’s AA can look ok, why cant SU’s!!! Dissappointment…


#12

I did read your posts. I was trying to help.

Where did you read that?

I don’t have a “monster” graphics card but I don’t have any issues with AA like what you describe.

I understand it’s frustrating when your hardware and its drivers aren’t capable of doing what you need them to do.

AutoCAD doesn’t use OpenGL so that’s an apples to oranges comparison.


#13

Where did you read that?`

Didn’t read it anywhere, I relied on my common sense, since I was able to use SU2016 without problems.
Ok, I’m all up for upgrading the program for users with better hardware, but al least leave an option for other users to revert the change, wouldn’t you agree?
And my graphics card is not that bad at all, I’m sure there are users that have hardware way worse than mine.
Intel Core i7-3630QM 2,4 GHz (8PCus)
8 GB RAM
AMD Radeon HD 7600M series - 6GB


#14

OK. Forget about everything I was rambling. I found a setting that gave me the look I was looking for.
It’s setting the “Multi sample anti-aliasing” to 0x. I don’t know what it did, but now it looks fine. The thickness has halved.
Thanks everyone for trying to help.


#15

FWIW, I expect you had Hardware Acceleration turned off in SU2016. This offloaded rendering duties to the CPU. That’s not an option.

I’m glad you found a setting that gives you what you need. Since there are so many different GPUs and driver versions, the give you the option to adjust that for best results.


#16

I wonder what your antialiasing settings are set to in the Radeon control panel. Things get messed up if the driver settings are set to something else than “Application controlled” or equivalent.
BTW, changes to SketchUp OpenGL settings take effect only when SketchUp is restarted.


#17

I thank you shared how you fixed the problem.
But then I have a question for the rest of users, 0x it’s not the standard value, right?
I think mine came with 4x. What’s yours?
I mean … I guess I shouldn’t change mine unless I notice some problem.


#18

@modeliranje3d,

Glad you found a setting that works for you. Do I understand correctly that your primary concern is the line weight, not so much line smoothness? Was your issue that the lines appeared wider when using a Multisample anti-aliasing setting larger than 0x?

For background, in theory the Multisample anti-aliasing setting should not impact line weight. If you see different line widths for different anti-aliasing settings that may point to a bug in SketchUp’s rendering code.

Also, I notice in the screenshot you posted that “Use fast feedback” is turned off. Is that needed to achieve the look you want?

Cheers,
Dominic


#19

0x would mean no antialiasing. That made me guess that modeliranje3d has antialiasing set on the system level.

Fast Feedback has no effect on the look of your model on screen. Usually you turn it on if you can do so without problems. If you have problems, especially with your mouse cursor and selection (trails, for instance), you can try turning it off. Turning it off makes screen operations marginally slower, but normally you wouldn’t notice.


#20

Yeah, I did the try by myself and I saw the difference.
Anti-aliasing x0 should in fact produce the problem he was reporting.
So settings on graphics card control panel has probably something to do with all of this as you suggested.