SU 2018 ugly rendering edges

#1

Hi!
I just tried out SketchUp 2018 and it renders edges in quite ugly way in viewport (and in PNG export too), as if they were doubled. Here’s a comparison how it looks in SU17 and SU 18 (see fullscreen):


It’s not just that I’m over-aesthetic. Neat rendering of edges has utilitary purpose - it shows whether there’s an unprecisely duplicated edge or not. Very useful when importing stuff from CAD. Now I couldn’t see that.
Can you tell me how it looks at your computers? Is it just my graphic drivers or Trimble spoiled that.

0 Likes

#2

It looks to me like the OpenGL anti-aliasing is set differently.

0 Likes

#3

Do you have the same anti alias settings in SU2018 as in 2017?

0 Likes

#4

Yes, AA turned off in both. I never turn it on.

0 Likes

#5

With AA turned off, you are going to see “jaggies”, and they may be different from one version to another due to subtle differences in the rendering (as well as the viewpoint).

0 Likes

#6

:frowning:

0 Likes

#7

Have you tried turning on AA? Smoothing the jaggies is what it’s for.

0 Likes

#8

They’re smooth then, sure. But using AA is though the worst thing you can do to model performance. And still doesn’t allow seeing very-close-but-not-overlapping edges.
I honestly don’t expect there’s a solution to this issue (small one, at first glimpse). Just wanted to know if others experience it as well.

0 Likes

#9

I’ve never had a problem with model performance due to AA being turned on nor have I ever found it a problem to see very close edges. The worst thing for being able to detect very close but not overlapping is having profile set higher than 1.

0 Likes

#10

To my understanding, when hardware acceleration is enabled (mandatory since 2017) AA is handled entirely by the GPU and should have a negligible effect on performance unless your graphics are inadequate. Is that understanding wrong?

0 Likes

#11

Whoa, don’t know enough about rendering to answer your question but on my computer AA makes sketchup slower.

0 Likes

#12

That may be something related to the Quadro graphics cards. They aren’t recommended as highly has the GeForce/GTX GPUs for OpenGL. Typically the comments seem to be the Quadros deliver poorer performance for more money.

0 Likes

#13

Are you turning AA on from the Nvidia control panel? You should leave the Nvidia settings to “Application controlled”, and if you want AA, turn it on in the SketchUp Preferences>OpenGL window. Note that SketchUp needs to be restarted after you make changes there.

What kind of screen is your screenshot taken from? Your graphics card model is one usually found in “mobile workstations” (I have at work a HP Zbook with a similar type card). Are you running your screen at 150% enlargement or higher?

Quadros usually don’t have problems with image quality, they are just slower when compared with a price/performance ratio. I would, however, check for a newer display driver version.

0 Likes

#14

It’s lust a laptop monitor. Sorry, Device manager doesn’t tell much about it.

In nvidia I have my AA settings set to “efficiency” so it’s off.

0 Likes