SU 2017 Poorer Line Quality


Having looked forward to the new graphics improvements in SU 2017 it is dissapointing to find that the on screen lines appear significantly more jagged than they did in SU2016.

The recommended OpenGL setting for the card is 4x, which is what we used in SU2016. The lines remain more jagged up to 16x, after which point they appear ‘smooth’ like they did in SU2016 - but we are warned not to use above 8x.

The card is an Nvidia Quadro M3000M and the monitor is a 32" WQHD, so all that should be fine.

Anyone else notice this? Any suggestions?




Sorry, just seen another thread on this here, so we’re not alone:

The general recommendation on there seems to be to increase the antialias multisampling. As stated above this does solve the problem but the issue is that when set on say 4x in both 2016 and 2017, the 2016 visual line quality is better.


SU 2017 internally renders 3D objects entirely different than in previous versions. There is bound to be some visual differences.

I set my opengl to 32X - check fast feedback and turn off Edge Profiles and set shaded with textures.

For the kind of work I do I see no noticeable slowdown. Here is a zipped kitchen.png using faststone capture 20 USD (687.1 KB)


2017 has a noticeable improvement over 2016 graphically. I can see it on my 47" screens clearly it is better and faster at generating complex files. I run mine with all max settings.


Nick, be happy to be on a windows computer. On mac it isn’t an improvement :frowning: but a step back into history! SU2017 on mac doesn’t support AA anymore! Back to the jagged edges :frowning:


No, you are not alone:

I find quite annoying that the lines will appear thicker than 2016 on high DPI screens (such as your WQHD) When the model has a lot of lines, the model is more susceptible to look just black blob.

and the anti-alias settings may improve, it doesn’t make it appear as thin as 2016.
I feel you @Guy (I know the pains of MAC is worse than windows. I moved on…)


Yes I’m on a windows machine. There are many reasons for doing so…now there is another. Sorry Mac folks, I hope they can get it to match the AA quality I get with 2017, because it is literally double the resolution of 2016.


Hi Guy, I’m on a older Mac Pro with a LG Ultrawide 2560x1080 monitor & a AMD HD 7950 open GL engine graphics card. I’m not seeing those problems with SU 2017
By the way, love the new version of Skalp


So, as long as you have a card that can run well at high anti aliasing settings then things might be ok. Mine goes up to 64x but gives a warning of potential slowdown from 16x upwards. The recommended setting is 4x and anything less than 32x shows more jaggedyness than 2016 did.

I’ll try running at 32x and see how things go with larger models.

None of this fully explains why the basic lines with lower anti aliasing aren’t as good as 2016 though, and from what Guy says above the situation with Macs sounds bad - so this issue might benefit from some attention.


Yes is the short answer. I run my GTX980ti max settings without any issues.


what is your AA settings?


Update: This issue seems to be fully sorted out now on SU2018. Huge improvement.


That’s good.

This was never asked but in SU2016, did you have Hardware Acceleration disabled?



We generally keep everything on unless there is a reason to turn it off, so I’m sure we would have had ‘use hardware acceleration’ ticked on SU2016.


This poor graphic Issue does not seem to be resolved in SU 2018. I must be missing something because I find it to be worse than ever. All Edges look like dashed lines regardlesss of orientation. Really maddening for detail work and embarrassing to show to a client. Its clear from all the posts on this subject since SU2016 that this is an ongoing problem. Doesn’t seem to matter what monitor, graphics card, setting etc you have. It always looks like amateur software when it comes to screen graphics. Id be happy if there were no new improvements in features for a while if SU could just fix the sub-par graphic performance