Edge line thickness in 2017+ (High DPI)

I just downloaded the new 2017 Pro version of SketchUp on my MacBook Pro Retina and am looking forward to using the many new great features but I noticed the basic edge thickness has increased. After watching the new features video I’m guessing this is a result of the new “HD monitors” support. ? If so I was wondering if there was an option to revert back to the thinner lines from 2016. When zooming out on a large complex drawing with many edges a lot of the details now get lost. I’m only viewing “Edges” and not “Profiles” etc.

2 Likes

Yes, it seems that the presentation of basic edges was changed based on screen dpi, and there is no user preference setting to adjust or select this behavior. Before this change, there were some things in the old GUI that were too small or thin to be useful (notably inference engine markers), but I was never put off by the edge thickness (or thinness if you prefer). I’d support a feature request to give us control of this, the way we have for profiles.

2 Likes

I’d second that - using versions older than 2016 on Mac, or any Windows version on laptop with about 1440x800 resolution, lines look very coarse and jaggy by comparison.

+1 for feature request to control the visible thickness of non-profile edges.

People have now been using retina displays for years and got used to it. You cannot just revert to an earlier line thickness display and not give people the option to stick with what they’re used to. Furthermore line thickness greatly influences visibility in certain styles X-Ray for instance. Please give us a setting to adjust this back if we wanted to. Thanks

There is some sort of issue with the new transparent options.
In my install of SU17, ‘nicer’ equals thick jaggies, ‘faster’ equals thinner lines and no jaggies.
might be a bug.
Just putting it out there…

+1 for this.

I did notice this issue and reported, but never been addressed.

I just installed SketchUp Pro 2017 on my iMac 5K system, and I was disappointed to see the thicker lines and coarser details compared to how SU 2016 behaved on the same system. I got used to the small inference markers etc in 2016 on the 5K display, and would love to have them and thin lines back. I’m really not sure whether I’m going to use 2017 or keep using 2016 at this point. Ugly! Bother!

1 Like

Any word on whether they’re fixing this fat line issue?

I just installed 2017 today, tried it out, and immediately went back to 2016 because of the line display thing. It makes the previously lovely thin edges look impossibly fat on my Surface Pro 3, which is not really a low resolution device! It looks like I’m back on an SVGA 800x600 display from ten years ago when I first started learning SketchUp–or maybe worse! Zoom out and it becomes a big blotchy blur of black, totally illegible! I’m shocked that Trimble could botch this so badly.

Just installed 2018 Pro and looks like the line thickness issue has not been addressed. I have two displays, laptop retina display and older Apple Cinema LCD (non-retina). The lines appear slightly thinner on the retina display and very thick on the other display.

I still don’t see any way to address edge thickness settings and this appears to have gone back to the 2017 release. Has anyone found a fix? I’ve emailed sketchup about the issue.

have you tried changing the AA settings in Preferences…

john

Yes, I tried that and from what I can see, it looks like it makes the lines look better, but they are still very thick.

Thanks for the suggestion,
Christopher

I have just encountered the same problem with the 2018 install - makes the software unusable for my purposes - what a shame, let’s hope SU will address after the break -
Neil

1 Like

Same issue!! Whats up?? I’m trying to use this professionally! Is anyone listening?

For 2018 there is a fix. I had to ask support to send me a small program to change the HighDPI scale factor to 1. Then the program looks great on non-retina screen. You’ll also want the “undo” of this, when you are on a retina monitor.

There is no equivalent fix for 2017.

I used this fix for 2017. add registry key:
[HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2017\Preferences]
“WorkaroundMaxSolidLineWidth”=dword:00000001

This doesn’t work for 2018 though… see the difference attached. come on sketchup, please address this chunky mess!
2017-2018

Hi

So it’s now two years later -
On my I mac - I abandoned the 2018 SU upgrade - because edges were just too thick - I continued fine wit 2016 until tis week when I upgraded OS to Catalina - 2016 then craches after 5 minutes. So now have SU PRO 2020 (FOR TRIAL PERIOD) Same problem with edge thicknesses - and programme is almost unusable - This is serious for me - You say you were sent a fix ? - maybe I will raise the matter with Trimble - but it seems things don’t change !

Can you show us? I’ve been using sketchup on macs for years and there aren’t any problems with edge thickness that can’t be easily addressed. From what I can tell there is no issue so you might just not like how sketchup looks.

I agree with @monospaced that it may come down to a matter of personal preference.

There were issues with high-dpi before SketchUp started to adapt to them and some growing pains as they worked on it, but I have been content for several years now with how it looks on my MacBook Pro Retina (formerly a 2012 15", now a 2019 16").

It would be nice if SketchUp provided greater control so that users could tune the view better for their preferences, but from my perspective this is a “nice to have” that can wait until more urgent bugs and issues are dealt with.

1 Like

Hi Ben
I have taken a screen shot of a model I created in SU 2016 (14.40.42) and the same view in SU 2020 (15.45.34) you can see how much thicker the edges appear in this later image. If there is a fix I would be very pleased to know about it - I can improve things very slightly by taking the edge profile down to 1 - but it won’t go lower.
I am very used to modelling on my I Mac - and found 2016 worked great - but this crashes with IOS Catalina - Also attached is my system spec and graphics spec. Hardware Overview.pdf (51.0 KB)