Why did lines (e.g. guides) become so thick in Sketchup 2017?

guidelines
constructionlines
lines

#1

Since I updated to Sketchup Pro 2017 all lines (e.g. edges, guidelines, construction lines) became awfully thick.
I have quite good eyes and I’d like them to be as thin in display as they have been with Sketchup Pro 2016.
Any help or guidance to change this in Sketchup Pro 2017 would be highly appreciated.
Thanks in advance.

A comparison of the same scale (left is 2016, right is 2017)


SU2017 faded lines
#2

Someone else started the same discussion recently. It seems that the antialiasing settings are failing to work in the 2017 Mac version. I don’t know the solution yet, haven’t seen any posts from the SketchUp team.


#3

Incidentally, you were not using antialiasing in the old version either, so at least you could get back to what you had before by opening the Styles palette and setting Profiles to 1 instead of 2.


#4

Hi Colin,
thanks, but it didn’t help to set the Profiles to 1 instead of 2. (btw had them at 2 in Skp 2016 as well). And it’s on the guides or in my examples on the axis lines, too. So changing the Profile to 1 doesn’t effect the axis “lines” either.

But I found another difference between Skp 2016 and 2017:
In Skp 2016 /Preferences /OpenGL there is the option of “Hardware Acceleration”. If I turn this off, the axis “lines” become thicker – just as in Skp 2017.
Unfortunately, this option is missing in the Preferences of Skp 2017…

Hope that the SketchUp Team will read this soon enough and provide some help and/or workarounds.


#5

There have been several posts about this. As part of the effort to improve support for high-dpi displays, the new graphics in SU 2017 increased the thickness of regular edges on these displays. Trimble did not provide any means for a user to override this effect.

Anti-aliasing is a separate setting that smooths out “jaggies”. It does not change line weights per se, though a smoothed line may look slightly wider and blurrier than an unsmoothed one.


#6

As slbaumgartner said, when the developers added support for scaling up the interface for high resolution display they also scaled up the line thickness.

I think SketchUp would really benefit of having a separate setting, e.g. in Preferences > OpenGl, to set the base line thickness. Most people seem to want the lines as crisp as possible, even when scaling up everything else.


#7

Thank you all for your help and clarifications.
I truly hope that SU will consider a separate setting for this.


#8

am not sure if this has any influence but you might want try the workaround to fix crash issues with AMD/ATI graphics cards by setting the max. solid line width to 2 pixels with a Windows registry file.

Windows .REG files are in ASCII text format and therefore can be edited with Windows Notepad e.g. for setting the line width to 1 pixel. Be aware that the value is a hexadecimal numeral, i.e. everything >= 10 … probably not very likely :wink: … needs to be converted from decimal to hex before.


#9

Thanks a lot, but I’m on a Mac.
best,
Ronen


#10

probably in the according plist file “/Users//Library/Preferences/com.sketchup.SketchUp.2017.plist” then … if implemented for the macOS version anyhow.


#11

Wow, that’s a huge improvement. I have a dell with the ANTI retina display, (768 px high!) and I felt like I was drawing with sidewalk chalk!!!

Way better now.


#12

I just upgraded and notice that the problem is on my external monitor, but not on my MacBook. When I drag the drawing to the monitor, the line weights increase. The MacBook has a retina display, the larger external monitor does not. This is a PITA because I use the larger screen for my CAD work. I may just keep using 2016 until SU can come up with a fix.


#13

For Mac, I sifted through the package contents, as well as the plist as @sketch3d_de suggested… But I could not find anything to edit as can be done in the registry on PC.

Anyone have any other suggestions on where to change settings on Mac side?

I hope this issue can be addressed by Trimble. It is a real visual step back to have to deal with profile-thick edges. As with @kabookie, Its ok on my Retina mac, but as soon as I drag a window to my LED display, it pops back to thick edges.


#14

There is not yet any preference or setting to vary the edge thickness on Mac, it is handled automatically in the SketchUp code. There have been enough complaints that we can cross our fingers and hope that Trimble will give us some control in a maintenance release.


#16

Hey, we’re moving my previous suggestion to the beta list - we don’t want to give anyone the wrong idea that something may work, when we haven’t tested it or shared with beta users to see if it does affect the configurations we want to help. Sit tight, and if it works properly, we’ll certainly share.


#17

So, did it work? Any updates on the situation?


#18

Please try installing our M2 release that came out in the past 2 weeks and report back.


#20

Downlaoded the update. Nothing changed in appearance unfortunately… Still have a thick “ugly” line compared to how it looked in previous versions… A real shame…


#21

On my macbook pro with 27" thunderbolt display I start sketchup, drag the window in which it says “start using sketchup” to the 27" display, then click “start using sketchup”. The drawing opens on the 27", and the lines are thin now on each display. When I start editing an existing drawing I first open a new one that way, then open the one I want to edit and close the new drawing. It works okay all the time.


#22

@Barry,

Mac has much less than what Windows have. But Window also suffers from same thickened edge problem on high-dpi screens.

:+1:

Maybe I just gotta keep complaining :smiling_imp: