Why the difference in appearance in 2019? Lines too thick!

Have a look at the two images below. The model is the same, the GL configuration is the same, the style is the same, but they look very different. In the one taken from 2018, the look is the same as it always has been. In the 2019 view, the lines appear too thick, as if there was a difference in style, but there is none.

The odd thing is that if I close 2019 and reopen it the problem goes away, at least for some time.

What could be causing this?

53

1 Like

Hi Edson,

To check, do you have more than one monitor? Do they have different DPIs or is one a retina screen and the other not?

I ask as it should work, but I’m curious if there is anything to do with what monitor SketchUp is launched on.

If you keep seeing this issue, could you please lodge a ticket with support and ask that they file a bug, as it’ll help us investigate.

I expietrnce the “thick line” phenomena while using external monitors with a retina MacBook. It’s most annoying to have sketchup look so terrible on both my side monitors but good on the laptop screen. I suppose it’s an OpenGL quirk and there is nothing to be done about it?

Doug,

My machine is an iMac with Retina Display (4096x2304 dpi) side by side with a Cinema Display (2560x1440 dpi), non-Retina. But, if this is the cause of the thick line problem, why does it not happen when I work in Sketchup 2018?

By the way, can you give me the support address? All the issues I have had so far have been raised through this very channel.

I have both versions of Pro on my iMac too. Is Depth Cue checked in the View > Edge Style > Depth Cue menu in 2019 ?

No, it is not.

I’ll follow up on it at this end. And have passed it on to see if we’ve had others run into this.

I’m certainly keen to understand the possible cause.

Hi edson, this is a result of SketchUp basing the screen resolution on the primary monitor being used when SketchUp is launched. When SU is launched on the laptop then dragged over to the other monitor, the resolution is calculated based on the first monitor. Dragging it back to original monitor will put the line thickness back to the original. This is existing behavior not new with 2019.

What you can do to solve this issue is move the SU window to the secondary monitor, Browse to SketchUp -> Preferences… -> Workspace then Rest Workspace.
Close then relaunch SketchUp and It should use the resolution based on the secondary monitor.

Let me know if this does not solve your issue.

Trent

4 Likes

Hi Trent,
Thanks for the tip. I have done what you suggested. So far so good. I’ll let you know if the problem reappears.
Regards.

I had the same issue when I switched from 17 to 18 and it was fixed with a script sent by the sketchup support to set the line weight to 1. ( I run sketchup on Mac book pro 13in late 2013) it worked that time but same is repeated now when I got 19 on my same system. Sketchup 18 and 19 open same file at the same time show two different results.

@designtreeindia, couldn’t you just set profiles to 1 and at the same time lower endpoints to less than what it is now, say to 2 or even disable displaying endpoints?

Same setting in both windows and one with end points disabled.
also one with profiles set to 1
please check.
Thank you


NAH . this is a different issue than setting Profiles etc. Everything looks clunky including softened edges and component boxes having coarse large dash patterns.
For me this was coming and going at first with 2019 but now. it is mostly not happening. I see it time to time. Actually these pictures don’t do it justice, it can make it hard to read what the edges are doing, especially with hidden geometry showing.

exactly… wonder why no one else is having it…! or are they not reporting?

Typically this is a graphics card/driver thing. What graphics card in your computer? Please complete your profile.

It may also have to do with the OS version. BTW when I do have it, it is the same on a high dpi 30” monitor as on the 15” Retina display.

Mac OS Mojave MacBook Pro 13" retina late 2013. No separate card intel Iris 1536

Your Mac is similar to mine but I have a 15in with nVidia card.

Hence my question. Not saying it was. Never experienced it myself.

SOLVED!
The script sent by Sketchup team (https://tinyurl.com/y5bzzrxz )was wrong it was specified for sketchup 18. I edited the file to make it 2019

#!/bin/sh
/Applications/SketchUp\ 2019/SketchUp.app/Contents/Resources/JSONPatchEditor HighDpiDebug DpiScaleFactor d 1.0

I even tried 0.5 and it worked

1 Like