New MacBook Pro M1 Max

I have just received a new MacBook Pro M1 Max from work.
Previously I was using my 2018 15".
I loaded a 2D plan that I was working on onto the new laptop and I cannot get it to look right.
Lines are broken and inconsistent on new laptop compared to old.
Any idea what is happening here.

Are the lines (edges)just not there or not displaying? Could this be fixed by adjusting anit aliasing or other display settings?

This is with SketchUp 2018 as indicated in your profile?

SketchUp 2022 is the only version that supports the new Arm / M1 Macs - so make sure you are using that version as a starting point

Thanks for the reply
Yes I am on 2022 version.

The lines are there, just broken up and not showing clearly.

As an experiment I exported the plan as a DWG and then Imported it back in and all is fine.
When I create faces all remains fine and no problem.

With the original ‘faulty’ plan.
I have also deleted the faces (attached) When faces are deleted the lines show as normal, but when I reinstall faces the lines go all broken again.

I have also tried all display settings and nothing fixes it.

Thanks again. Any help much appreciated.

Sorry will update my profile as I am on 2022 subscription now.

Can you post the original file that shows these problems?
Are you using a “sketchy edges” style?
Is there a difference in screen scaling?
Is there a difference in the Antialiasing settings in Preferences>OpenGL?

The open GL settings are the same.
No sketchy edges
Screen scaling-not sure.

I have attached a section of the original plan as a Sketchup file
A screen shot of the same plan as seen on my Old Mac and New Mac

Thanks again
Example of plan.skp (149.3 KB)

This is on windows so it is only for comparison, as you can see there are no issues with any edges so there is nothing wrong with the model itself, which suggests it is a graphic card issue, or at least how Mac is using the graphic card.

Yes that was my concern.
This problem only seems to arise when opening an old plan produced on my 2018 Mac.
Not when I start again with a DWG generated on the new Mac.
So there is a fix it just seems odd and bit of a worry.

I see the problem on M1 and M1 Max. It looks the same in 2021, so it’s not because of SketchUp running native instead of with Rosetta. Something about the M1 GPU seems to not like those edges.

I will ask the developers if there is a known issue.

I found that if I flatten the geometry the lines then look ok. It may be a variation of z-fighting, where edges that are microscopically away from the face may appear behind the face.

I use this extension to flatten the geometry:

1 Like

It may be worth noting that you have length snapping enabled and set to 1mm. Best turned off.
And if you adjust the precision of the units display you can see the tiny discrepancies in the z plan that Colin is talking about.

Thank Colin that totally worked.

And you are right I can see that now.
Thanks everyone