SketchUp on Apple Silicon, M1 devices and issue reporting

Apple has a new CPU on the market and has released a handful of Mac computers using the M1 processor. All of our internal testing and reports from early adopting users suggest that SketchUp is stable on M1 Macs, and that it’s running pretty quick too!

Notably, SketchUp is supported by Apple’s Rosetta 2 translation service on this hardware. However, this is not our long term plan for supporting Apple devices.

While we’re pleased with the results of our testing, there has to be a catch right? Something is not going to be perfect… that’s the point of this thread. If you’re using an Apple M1 based computer, running SketchUp and you have a problem, please post below. Be sure to include the following:

  • Computer Model (eg. Macbook Air M1, Macbook Pro M1, Mac Mini M1)
  • System Memory (eg. 8 gb, 16 gb)
  • SketchUp Version (eg. SketchUp Pro 2021, SketchUp Web)
  • If you’re using SketchUp Web (Free or Shop), be sure to include which browser you’re using.
  • Description of the Problem
  • SKP file if the problem is file specific

As this thread is for the purpose of identifying issues, we’ll be a bit strict on staying on topic. If you have other things to talk about, be sure to bring it up in the appropriate category elsewhere.

3 Likes

Known Issues:

Issue: When working with transparent materials, you’ll see some undesired artifact behavior if you have “Nicer” enabled rather than “Faster”.

Workaround: Open the Window > Styles, go to the Edit tab and choose Edit, Select “Faster” setting from the “Transparency Quality” drop-down options.

I have a MacBook Pro Apple M1 chipset 16GB ram… when ı use Sketchup pro 2017 my project about 350mb files ı can open… ıts not a problem but when ı use Sketchup pro 2021 ı can’t open project and program is fall… what can ı do…

What happens when you try to open the file? 2021 does some fixing of things, and jumping from 2017 to 2021 could lead to a lot of things that have to be fixed. Give it more time to open the file.