SketchUp on Apple Silicon, M1 devices and issue reporting

Apple has a new CPU on the market and has released a handful of Mac computers using the M1 processor. All of our internal testing and reports from early adopting users suggest that SketchUp is stable on M1 Macs, and that it’s running pretty quick too!

Notably, SketchUp is supported by Apple’s Rosetta 2 translation service on this hardware. However, this is not our long term plan for supporting Apple devices.

While we’re pleased with the results of our testing, there has to be a catch right? Something is not going to be perfect… that’s the point of this thread. If you’re using an Apple M1 based computer, running SketchUp and you have a problem, please post below. Be sure to include the following:

  • Computer Model (eg. Macbook Air M1, Macbook Pro M1, Mac Mini M1)
  • System Memory (eg. 8 gb, 16 gb)
  • SketchUp Version (eg. SketchUp Pro 2021, SketchUp Web)
  • If you’re using SketchUp Web (Free or Shop), be sure to include which browser you’re using.
  • Description of the Problem
  • SKP file if the problem is file specific

As this thread is for the purpose of identifying issues, we’ll be a bit strict on staying on topic. If you have other things to talk about, be sure to bring it up in the appropriate category elsewhere.


Known Issues:

Issue: When working with transparent materials, you’ll see some undesired artifact behavior if you have “Nicer” enabled rather than “Faster”.

Workaround: Open the Window > Styles, go to the Edit tab and choose Edit, Select “Faster” setting from the “Transparency Quality” drop-down options.


I have a MacBook Pro Apple M1 chipset 16GB ram… when ı use Sketchup pro 2017 my project about 350mb files ı can open… ıts not a problem but when ı use Sketchup pro 2021 ı can’t open project and program is fall… what can ı do…

What happens when you try to open the file? 2021 does some fixing of things, and jumping from 2017 to 2021 could lead to a lot of things that have to be fixed. Give it more time to open the file.

I am currently using the new Apple Mac Book Air M1 with 16GB ram running Mac OS Big Sur 11.2 and it seems to crash while using the plugin Twilight Render Pro V2 12.15.3.while doing Batch Rendering. I have raised this with the Twilight Team.
Update : I have spoken to Cadsoft my distributors in the Uk and was told not to use rendering software as this is not supported on new architecture and wouldn’t be for a while, can I check if this comes under support of SketchUp? I have just uploaded an older model and this worked fine. I have been in touch with Apple and they have guided me through uninstall and re-install but this has not changed my issues.

I’m frequently seeing the beach ball of death. Is there a way I can can pin point which part the model is confidentially heavy?

I’m using Sketchup Pro 2021 on a Macbook Pro 13" M1, 16GB RAM
I’ve had Sketchup and Layout crash quite a few times. I’ll very often get the spinning rainbow when zooming in or exploding groups to edit.
The more lines or faces in the model, the worse the problem. This happens in all files, so it is not particular to one specific model. It’s not exclusive to lines or faces, as some of these files are lines only. Previously, I had a Macbook pro 15" (2015 model) and it worked without issues on the same Sketchup files (but on SU Pro 2017).
Is this possibly an issue becuase of Rosetta? Is SU aware of the issue and are there any fixes under review?
Thank you for a great product, otherwise. Long time user here!


I hope so as I really like the new M1 MacBook Pro I have. I have not ventured to try out SketchUp yet on it. I heard Parallels is not up to speed for SketchUp either yet.

My M1 iMac only arrived today. I’ve only done a couple of tests so far, one of which involved 10,000 copies of Sumele orbiting around the place. Roughly speaking, the performance was much like my work MacBook Pro (Intel), which is a similar machine to the one that Aaron demos on each week. For an emulator it’s pretty good, but I am hoping that some other tasks may come out better. I did a render test in Final Cut Pro, which on my 16 GB MacBook Pro took 6 min 40 sec. On my iMac, which is the lower 8 GB model, it was 5 min 22 sec.

If you have any models that show problems, or you notice a particular set of actions leads to a spinning cursor, let me know, and I’ll check to see what I get.


Here is the model.

The issue can be replicated every time I try to explode the main group in the model. Please let me know what you find.

Thank you.

There’s at least two issues. One is that it’s taking a long time to explode the group. I set my iMac and MacBoo Pro working on it a while ago, and neither have finished.

The other issue is that on the iMac the rainbow cursor stops spinning. I don’t know if it’s still working, and only the cursor is not being updated. Moving the cursor slightly gets it spinning again.

The cursor freeze, and some other freezes, seems to be a known issue with the M1 machines. Here’s an Apple and a Reddit topic about the problem:

I am fairly sure it will be a software issue, some of the people seeing the problem had their machine replaced, and still they see the problem.

I’m going to take a break for an hour, and will check both machines to see if they finished exploding that group.

I was about to head out for a while, but checked my two machines. The iMac, that had been sat there without a spinning cursor, had finished the explode. My MacBook Pro has not yet finished the explode.

I reverted the file on the iMac, and set it exploding again. This time I won’t move the cursor at all, and it is already not spinning. I’m expecting it to have done the exploded when I get back.

Hey, my MacBook Pro just finished! Hopefully the non-spinning cursor is an oddity, and not something that means the machine isn’t still working on the task. I will still look into why that group takes so long to explode.

When I got back I checked the modified time of the auto save file. It looks like it took my iMac 15 minutes to do the explode, but at least it finished, even if the cursor wasn’t spinning.

I don’t have an M1, but looking at that model on my Intel MBP, I see that the dwg component has 726128 edges but only 139 faces. Could it be that SketchUp is beating itself to death finding all the possible faces associated with those edges?

This topic was automatically closed after 186 days. New replies are no longer allowed.

I’m getting some strange artifacts on faces on a 95MB file when zoomed out. You can see the issue in this photo. (When zoomed in, problem goes away) M1 MacbookPro 13" 16GB
The model has 33,000,000+ faces and 52,000,000+ edges.

It is insanely enormous.
You are viewing in Parallel Projection mode. The artifacts also look as if the model has very large extents (many kilometers) or if it is a long distance from the model origin point. You might also have z-fighting (two or more faces at the same place)

1 Like

Is it possible there is a component or group that has an object with a very large extent in it? I can’t find anything in the unexploded model that is “many kilometers” away. (The original model is not mine)
AS of now, the model has become unusable - I don’t know why . I’ve added a few things to it, but minor. Then I made some section cuts and the model is now unusable (crashes sketchup). I finally got the file to open on one instance and have removed the section cuts and re-saved… but it is still unusable. I just now tried to open up the components window to see what items could be using up all that geometry, but I am currently frozen.

If you can upload the file to a web sharing site like dropbox or google drive and post the link here then one of us can take a look and see exactly what is going on. Your geometry statistics that you posted are off the charts enormous, enough to choke any machine, and is very suspicious of sloppy or over detailed modeling, or of imported cross format objects that arrive tessellated with many faces.

The graphics problems in your picture do look like open GL problems that arise with very distant from origin models, and very large models. This can happen if you import from another format that places objects relative to the origin. There are a few causes of very large distance models that are not all intuitive to trouble shoot. We would need to look at your file to diagnose.

1 Like

Hi endlessfix - the file is not mine so I don’t think I can share it ; but I DID see that this chair in the model has 74,000 faces, and there were a few hundred of them… probably accounting for 15-20,000,000 faces: chair in model - I don’t know if there is a way to minimize the geometry quickly in this component to keep it in the model. I also found some leafy plants that accounted for a few million faces, and some lines (i think a previously 2d CAD underlay) that accounted for a few million edges.

I have the “clean” model down to 2,700,000 faces ( I left about 30 pieces of furniture in the space that I need to see to design around, which probably account for MOST of that geometry)

but I am still having graphic issues. Currently the app is stalled, I took a screen shot - as you can see the section plane is GIANT which I’m guessing is due to some random geometry or texture that is very distant? (see the model - it’s that tiny spec in the lower right corner… the model itself is maybe, 200’ x 200’ wide)

So to both your points about the very distant objects, is there a way I can figure out what’s creating it?