Badly rendered Edges - video settings? SketchUp 2023?

Folks I’m getting some odd rendering of edges in SketchUp 2023

This screenshot shows a number of edges/faces which i drew (fairly random)
They are all okay geometrically - no overlapping lines or stray edges, gaps, etc…just clean linework.

The thing is, i have Profiles turned ON and I can’t see the difference between Profile edges and regular edges, in some cases.
This is because many edges (including edges drawn exactly on the Red or Green axis) are rendering on my monitor as approx 2 pixels in width.

If I zoom out then the 2-pixel edge rendering effect is still present, but this time different edges are affected.

As I zoom in and out, the edge thickness “flickers”. Not pretty.

Is this normal in 2023 or do I need to re-check video drivers, cables, monitor settings, etc.
I am using Nvida RTX 3070ti mobile, etc Studio drivers. External monitor is a 4k 32" (looks fine in all other software) Internal laptop monitor shows the same rendering issue… Nvidia settings are default (“quality” 3d image rendering).
SketchUp is set to 4x AA and I’ve tried 8x with no apparent difference.

Not sure what else to try.