Graphics card unsupported (Have Intel UHD and nVidia cards)

I am having an issue with installing Sketchup pro on Dell machines that have 2 graphics cards. Sketchup will try and use the UHD and tell me that it is unsupported. If I disable the UHD card then sketchup will work. How can I force Sketchup to use the nVidia?
I have setup the nVidia control panel and the advanced graphic settings within windows but the only way I can get it to work is by disabling the UHD graphics card. I have run the sketchup checker and here are the results:Results:

Error: Something went wrong while retrieving the system information from your computer. This may cause tests regarding System RAM, Windows version and/or graphics card memory to fail.
Error: Graphics card information is missing.
Warning: SketchUp has detected you are using a “Intel® UHD Graphics 630” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.
Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!

The Checkup program found some errors (listed above). You may need to take some action in order to run SketchUp 2021.

See Help > Documentation for more information.

Please advise

I also have a Dell system and I don’t have this issue. What is your BIOS setting for video? Mine is an older Precision T1700 and mine is set to “Auto”. I had no issues installing SU (any version so far) on this system. I am using an Nvidia GTX 650 Ti and all is working as it should.

Right click on the desktop and select the Nvidia control panel. In the control panel are settings that can will allow SketchuUp to use the Nivdia card.
1

I have seen about two different Nvidia panels Mine looks like this:


You should set the “OpenGL rendering GPU” setting to point either globally or for SketchUp directly to your Nvidia graphics. (I don’t have to care, as the i7 CPU in my desktop doesn’t have integrated video)

And this is from my Ultrabook, where you select the card from the popup menu at 2.:

  • That is already set to nVidia for Global and Program settings but still get the error:
    *

Do you have the latest driver from Nvidia installed? Do not rely on Windows to supply it.

Desktop or laptop computer?
If laptop, are you using an external monitor? Is it connected via a “dock”?

You should also set your “preferred graphics processor” to the Nvidia card, at least in the Applications window for SketchUp.

The newest drivers are loaded for both video cards.

Laptop with no external monitor attached.


Processor is set correctly…
I have built images for deployment to over 100 machines and I have never had this issue before.

1 Like

Download this Utility, run it and look in the lower left corner to see which video card it is looking at.

It shows both:

It should work. What does Dell have to say about the matter? Frankly I have no other suggestions.

Calling Dell now and will let you know.

1 Like

Not trying to be “that guy” but you’ve done something. I have 2 Dell desktops and both have Nvidia cards and SU install on both was basically double-click and go. Good luck and I hope you get a solution :frowning:

Edit: Saw above that you’ve built machines before. Do you think it might be a bad piece of hardware?

I have tried on multiple models of Dell Precision machines and they all have the issue.

What? That’s weird. I also have 2 Precision models and they were like I said, “double-click and go”.
Home model is a Precision T1700, I bought it off Newegg as a refurb and I have a Precision 3630 at work. That one is “managed” by work but no issues with that. They send out updates when IS has tested them basically.

Is there a bios setting that could possibly come into play?

1 Like

I had to disable Intel graphics in a BIOS to be able to work properly in my Dell Precision 7530 laptop.