GL clipping

I am getting the problem that when I zoom in, the model gets clipped (an invisible plane seems to appear). I have tried to diagnose this with my reseller, but we can’t get to the bottom of it. When I copy a simple model that is doing this into a new file from template the problem seems to disappear. However, when I did this with a bigger model the problem persists.

The reseller thought it could be to do with a template being set up in mm rather than metres or a graphics issue (maybe caused by new drivers in Mac Catalina update).

baffled so far!

What version of SketchUp? Please complete your profile.

Which operating system? Your profile indicates Safari as the operating system. Safari is an internet browser, though, not an operating system. What graphics card? Apple Macbook Pro doesn’t answer that question.

Is the camera set to Perspective or Parallel Projection?

Is the model large or is it or some part of it at a great distance from the origin?

Relative to the size of the entire model how large is the object you are trying to zoom in close to?

See also the help center page about clipping.

updated profile - thanks
camera perspective
Small model is doing it close to the origin and have opened up some older projects, that are larger, that weren’t a problem at the time, but are now also clipping

Thanks for updating your profile. Can you share a .skp that gives you this problem?

There is an issue in 2020.1 specifically. If you see clipping, type shift-z to zoom extents, then zoom in again. If you’re very close to the model there may still be clipping, which is unique to 2020.1. It’s the kind of thing you would hope we will fix soon.

hmmm - that would explain why I am seeing the problem with models that I didn’t see it with before. Thanks for letting me know. Please fix it Sketchup! :pray:

1 Like

We sure do!

My distributor doesn’t seem to think this is the root cause as he believes the problem is specific to the template the file is created in not the build number?

We have found that if you copy a model into a new file from template the clipping can disappear? Is this explained by a 2020.1 issue?

thanks - checked all those things and problem still occuring

The new model will bound to have a different camera position. The clipping is usually to do with the camera position.

If you’re able to give us a copy of the template I can test if it seems to be the 2020.1 issue.

I am flying around the model in both versions to test the issue (using 3D mouse) - can you expand on how to test if it is anything to do with camera position - I’m not sure what you mean?

I have attached a VERY simple model that is causing clipping - and screenshot example
test 2.skp (2.6 MB)

Your model has a different variation of the problem, and the way that you move the axes shows that the problem is still there if you move the origin to the model, and not the model to the origin.

If you right-click on an axis and choose Reset, you will see that the model is 1135 feet away. That’s enough to exaggerate the clipping. Normally moving the model back to the origin would make it be better, but something else is strange about the model, not counting that Laura doesn’t face the camera.

I figured it out eventually. Clearing the geo location fixes the clipping.

I’m testing to see if whether the exact location affects the amount of clipping.

Um, could the clipping have anything to do with the absurd ratio between the size of the visible stuff and the size of the terrain and image that use non-visible layers?



It’s the kind of thing you would hope we will fix soon.


Still hoping.

Thank you, Colin.

Best, as always,

yes - I see. thanks for taking the time to look at this.
I’m not sure why the axes had moved from their origin

I use that geo location in my template as it then sets up shadows in the right way and the extent of the map is helpful as that is the area I often work in. Is the geolocation problem part of the 2020 issue? Can I use a geolocation (other than the Sketchup Car park?!) that won’t cause the clipping issue?

I also tried resetting the geolocation and checking the origin on an older real project file. Also did the ‘zoom extents’ thing. Still getting a bit of clipping - is that likely to be just the 2020.1 issue?

As @slbaumgartner demonstrated, the cause for the clipping is the large piece of terrain you have in your model. When the model extents are as large as this (it seems to be miles across) clipping is bound to happen in any version of SketchUp.

not sure if you are seeing the whole thread, but geolcation was reset/removed and some clipping still occuring, which it sounds like is a known issue in 2020.1