Strange behaviour when zoomed in


#1

Hi, I’m using Sketchup Pro, and this particular model is behaving strangely. When I zoom in a certain amount, the view cuts through the exterior of the model. Hard to explain, I can email a screenshot if this site supports that?
The model is based on an imported dwg file, but I often do this and don’t have this problem. There are other strange things going on with the zoom and orbit which seem to be swinging around a bit erratically. I’ve tried doing view all and erasing anything that is far away from the area I’m working on, and I’ve purged unused entities, but still not working as it should. Any ideas?

thanks!
Rose


#2

Search for Clipping or clipping plane.


#3

Imported dwg files frequently have this problem because AutoCAD merrily places coordinate origins far from the model contents.

http://help.sketchup.com/en/article/36261


#4

Thanks! I have tried the fixes in the little online tutorial without success - model is on the origin, all extra geometry deleted, including on hidden layers, dimensions and zoom level are normal - but it’s still clipping when I zoom in! Any other ideas?


#5

Hi Rose,

Confirm the camera is set to Perspective

Look to the top menus…
Click … Camera > Perspective


#6

Thanks Geo, I have checked and it is!


#7

When you click … Camera > Zoom Extents … the model should fill the screen.
Does it?


#8

There is white space all round, but not more than 1/3 the total screen dimensions


#9

That suggests there is still some stray geometry that you haven’t managed to delete. It may be so small it is difficult to see. Make sure View->Hidden Geometry is on and that all layers are visible. Drag a left-to-right selection box over the empty space (be careful not to select part of your model). See if the entity info window says you selected anything. If so, hit delete. Try this on all of the blank space around the model.

Also do Window->Model Info->Components and check the “show component axes” box. If you then see little coordinate symbols in the white space, the problem is with the origin of a component.


#10

Sounds like there still could be some stray geometry far from the model.

In this order click …

Edit > Select All
Camera > Zoom Extents

Now carefully deselect only the model parts you know you want to keep.
Entity Info will then probably indicate ‘other stuff’ is still selected. Hit Delete


#11

As another thought, how large is your model? If it tries to cover an entire city (for example) it may be too large for SketchUp’s viewing system to stay sane. That’s a known limitation.


#12

Don’t you hate it when we post essentially the same idea at the same time :smiley:


#13

hi, it’s just a house and back garden! I’ll try the other fixes…


#14

I’ve done all these things and still same problem!


#15

Hi Rose,

Perhaps the easiest thing to do is allow us to work with the file.

Attach it to your next post or upload the model to the 3D Warehouse and post a link or the exact name and author so we can find it.


#16

Hmm. If you zoom very close to something, SketchUp deliberately clips objects that would be behind the camera. This lets you, for example, zoom to the interior of a building. Could that be what you are experiencing?


#17

no, this is happening way before I get that close. I’ll try to upload the model to the 3D warehouse…


#18

Hi, I don’t know how to post a link but it’s called roselands garden and the author is Rose L. - hope you can find it!


#19

Found and downloaded it. When loaded into a model via the 3DWarehouse, it naturally comes in as a single component. This component has an enormous bounding box, confirming that there is either still stray geometry or misplaced axes. My SU is throwing a stall while exploding the component, but I’ll get back to you with more info when it finishes!


#20

There is a bunch of geometry located way out the red axis from the main contents of your model. Looks like plans for a car?