Geolocation not working

geolocation

#1

Hi all,

When I try to geolocate in SketchUp, I get this screen appearing. Completely in grey, no selectable map area. I usually running Google Chrome, but I read other articles with people having the same problem, and I’ve set the default back to Internet Explorer 11.

Computer Stats:

Windows 10 Home
MSI GP60
i7-4720HQ 2.60 GHz
RAM - 16GB
64 bit, x64-based processor

No combination of clearing cache, or any other option seems to work. Does anyone have a workaround or advice?


#2

Keep trying … here’s the guide:

Can’t connect to web tools — SketchUp Help


#3

I followed that article to the letter. In related news, my Revit geolocate also doesn’t work. I think it’s a Windows 10 thing, based on previous forum articles, but it begs the question: why does SketchUp use IE (now out-of-date, in favour of Microsoft Edge) to access a Google product? Not being a troll about this, but it seems like it’s a method that’s doomed to inter-operability issues.


#4

Firstly It’s not a google product!
Secondly IE is the current standard for PC and Safari is for Mac.
So sketchup uses the browser that is installed by default rather than forcing you to install a browser you may not have just to make sketchup function.

If revit isn’t working also then it is a system problem rather than a sketchup issue.


#5

I’m well aware that Trimble bought Sketchup away from Google.But Google Maps and Earth remain Google products.
Microsoft Edge is now the standard browser for Windows 10. It replaces all file associations set with IE. Once again, not being a troll, just considering the situation.

Has anyone that continued to have a problem after following the document, found another workaround?


#6

Not everyone is using Windows 10 yet. Many are still using Win7 and some Win 8/8.1. Have to look at the whole situation.


#7

Not for embedded apps. Please launch IE and try 3dwarehouse.sketchup.com/add location.html


#8

3dwarehouse.sketchup.com/add location.html - HTTP 404 not found.

3dwarehouse.sketchup.com/ - webpage opens, no picture content (thumbnails, logos, etc) in frames, only text appears

Internet on Chrome of course, works fully. IE security settings set to full exception control on *.sketchup.com, running at lowest security settings overall.

IE on left, Chrome on Right - addLocation

IE on left, Chrome on Right - 3dwarehouse


#9

I’ve gone back to IE, made sure all my Java and Shockwave settings were set to enable. No script disabling at all. Very low security settings (no big deal to me, as I use Chrome for most of my affairs). I’ve uninstalled, and reinstalled Silverlight. I went to the Adobe Flash page, to confirm that Applets and Shockwave objects work. But it seems that everything in a box that’s rich media content (preview of models in Sketchup 3d Warehouse, or Geolocation) just refuses to work. I can see in the search box that the location is registering, but all I get is a grey screen.


#10

This is front-ending a Google Maps API. What happens in IE if you just go to maps.google.com?


#11

More grey screens. Links and the Google menu are still accessible, although not visible. It defaults to Google Maps Lite, as I found out when clicking the menu for more information.


#12

While it may use Google Maps Lite, it uses a different set of imagery than you may see in a browser window. I realied that Sketchup is using a more recent image for many of the geolocated places that I brought into the model. The strange thing is that when I use the USGS Earth Explorer I get the same image I see in Sketchup, but the Google Maps browser interface shows older imagery. That’s another GREAT thing about Sketchup - the latest imagery!


#13

I ended up having to use a Mac to get the images to work… it’s a shame, hopefully this can be resolved otherwise.


#14

Do you want us to fix Revit too, for you, while we’re at it. Sheez…


#15

No, I have another question on the forum at Revit regarding this issue. I kept the SketchUp stuff on this page, as it related to the issue, with SketchUp. As a SketchUp team member, you’re responsible for your company’s image.

Stay professional, Barry.


#16

The fact that you get the “grey screen” when you try to access Google Maps in IE, indicates it isn’t a problem with SketchUp.

Entering the lat/long from your screen in SketchUp gives a location indicating that it does indeed work just fine with Windows 10.


#17

Saying “I’m not being a troll here” does not mean you’re not a troll. If you can make it work in IE, and avoid some simple mistakes, like typing

3dwarehouse.sketchup.com/add location.html - HTTP 404 not found

instead of

3dwarehouse.sketchup.com/addlocation.html

you might be successful.


#18

It didn’t work, when I tried. I tried multiple times, and I must have dropped the space when I tried to take the screenshot. But the result was no different, between the screenshot, and the time I copy-pasted your url into my browser.

“Not for embedded apps. Please launch IE and try 3dwarehouse.sketchup.com/add location.html”

Thanks for your attempts, Barry. I’ll get this one another way, with someone else’s help.


#19

I have the same problem: When I select “Add Location”, a window opens up and is blank except for what could be either a search window or a drop down menu. This was working some time before but no longer.

I’m using version 2016, on MacOS 10.10.5 (Yosemite).

Does anyone have an update on this?


#20

• SketchUp Help Center : FAQ for Add Location changes in SketchUp

SketchUp 2016 (Pro or Make) and older versions of SketchUp

At this time, there is no feasible way to update these versions of SketchUp to use the new geodata service. The Add Location and Photo Textures features will no longer function.

effective since: 22.05.2017