Geolocation Bug

Hi, my geolocation is only showing bodies of water. No satellite imagery. Also, when I try to import the site it freezes. SketchUp pro 2021.

The little square to the right of Map type, shows that you are not in the satellite view mode. What happens if you click on that?

Colin,

See attached. No difference. I have also tried solutions I have found on the forums like clearing internet explorer cache with no success.

Thanks,

What is the location?

Dave,

It is not tied to any location. Same situation everywhere.

Thanks,

1 Like

Can you right-click somewhere and choose to show the dev tools? Then look in Console to see if there are errors happening.

Interesting.

Out of curiosity, when you installed SU2021, did you right click on the downloaded installer and choose Run as administrator?

You could try repairing the installation of SketchUp. It won’t hurt anything and won’t take long to do. Quit SketchUp, find the installer, right click on it, choose Run as administrator and then choose Repair.

Colin,

Definitely looks like there are some errors.

Dave,

An IT company manages the installs on this computer. I will say it worked for a couple of months after installation. This issue started a couple of weeks ago. I will ask ask them to repair.

Thanks,

Notice that the date of the code is from 16 days ago. There may be something in the latest code that is causing a problem.

@Bryceosaurus, who would be best to look into that?

Merica :slight_smile:

Has this issue improved at all? What you are seeing is that no map or imagery “tiles” are making it down to the add location service. Almost seems like your internet went out right after add location loaded.

If it’s still not working can you check if you can you access 3D Warehouse or Extension Warehouse?

Hi Bryce,

The issue has not improved. 3d Warehouse and the Extension Warehouse both work with no problems.

Thanks for checking. We’ll look into that error as it does match the date of our recent update. FWIW I’ve never seen the issue you are seeing so it’s definitely suspect.

Can you tell me your operating system version and what version of sketchUp you’re using?

I’m experiencing the same issue, as are all of my coworkers who use Sketchup. We all have Windows 10 and are using SketchUp Pro 2021.

SketchUp 2021 and Windows 10 here as well.

1 Like

Hey Pbright

We just pushed a fix for some errors. Can you check if that improved your situation?

Bryce

Andrea can you check if this is still happening? We pushed a recent fix but since we have yet to replicate the issue we’re not sure if it improved things.

I ran the latest update that was available, however still no luck. I’m seeing the same thing in the GeoLocation window.

Thanks for the info we’ll take another look.

One other question for you Andrea, do you know if this issue started recently? We’re trying to figure out if this could be a firewall type issue or if it’s something that started with a recent update to the Add Location service.