Geo Location does not load

geolocation
su2016
whitescreen
blankscreen

#1

Hello,

When I try to use the geo location (Sketch up 2016) the page does not load and the button’s do not work (see image below). I’ve tried the steps from the knowledge center (clearing cache, DNS, …).

If I use the url (https://3dwarehouse.sketchup.com/addlocation.html) in chrome it does work, not in internet explorer, but in the program itself it still does not work.

All tips/help is welcome!

Thank you


#2

SketchUp uses EI to display that page. You may try to update Internet Explorer, and try again.


#3

And you can try opening IE and going to https://3dwarehouse.sketchup.com/addlocation.html to see if that page is white or if it brings up the map. You can’t use it in a browser, only in SketchUp, but it’ll help figure out where the issue is. Clearing IE cache might help, and see other threads about clearing caches in your browser and in SketchUp.


#4

Thank you for replying so quickly. When I go to
https://3dwarehouse.sketchup.com/addlocation.html in IE it’s a white page,
the same as in Sketch up, if I go to the link in google Chrome it’s a map
like it should be I guess. I’ve tried clearing IE cache and that did not
help unfortunatly.


#5

Did you try checking for updates in IE?


#6

So we know you can get to it on your machine (not a network problem; it’s an IE problem).

You might just try

  1. Going to maps.google.com, go to earth view to see if that works.
  2. Checking IE security levels to see if that’s somehow blocking things.
  3. Search the internet to see if others see this on your version of IE.
  4. Do as @DaveR says above and check for IE updates.

#7

maps.google.com works in IE, I have the latest version (IE 11, there are no
new updates according to microsoft). The security settings are the standard
ones (medium high), I’ve also added this
https://3dwarehouse.sketchup.com/addlocation.html to the trusted sites. If
you can think of anything else I can try please share I’m also checking if
I find anyone with a similar problem.


#8

First you have to be able to bring up https://3dwarehouse.sketchup.com/addlocation.html in IE.

You’re going to have to google (verb) why IE can’t bring up that page, because it’s some setting on your computer doing it.


#9

Could be a AV or Firewall app blocking SketchUp specifically from internet access.

@karen_walbers

Are you signed in ?
(The 3rd button from left, on SketchUp’s bottom statusbar.)

Does the Extension Warehouse feature work from within SketchUp ?
menu: Window > Extension Warehouse


#12

As stated above, SketchUp internally uses the Microsoft Internet Explorer browser control library object to display WebDialogs from within the SketchUp application, under the Windows platform editions.

This library object (a DLL file,) is often updated if the entire Microsoft Internet Explorer package is updated. So it is recommended to install any updates to MSIE, that are made available via Windows Update.
(If you have automated updates turned off, then you’ll need to check for and install updates manually.)


#14

@DanRathbun

yes I’m signed in and the extension warehouse does work


#15

So here are the web properties you should try:
Extension Warehouse
3DWarehouse
Photo Textures (draw a face, right click on it and click Add Photo Texture…)
File->Generate Report

Do all of those work, but Add Location doesn’t?


#16

I’ve tried the web properties you suggested and only the extention
warehouse seems to be working. When I tried the generate report I got the
following error: internal error in microsoft internet extentions
@/compiled_f87ee.js[498]. There was no error screen with any of the other
web properties.


#17

Hi Karen. I have the same problem! Did you get it resolved?


#18

Try resetting IE and see if that helps


#19

Hi Sigtaubert, I did not find a solution yet. I’ve tried all suggestions people gave here but they did not work. I hope you’ll find a solution. If you do, please post it here than I’ll try it as well. (I’ll do the same.)


#20

Hi Karen. This is unsatisfactory. I have had 2 emails from Sketchup support team saying there is no support for Sketchup Make users and that I should be able to find the answer in the forums. Perhaps you could also email Sketchup Support prosupport@sketchup.com and tell them you have been waiting for a solution since December!


#21

Hi Sigtaubert. This is indeed unsatisfactory, I’ll send an email to that adress like you suggested. It is clear we will not find an answer on the forum.


#22

Try resetting IE it does not take much time and may help


#23

Yup. Clear. Not gonna happen…