File exception 0 when saving locally on PC

I get this error message at least 50% of the time when I save while using the program and about 25% of the time while closing the program. save error 0 ! It doesn’t seem to matter if it’s a large file or a small file I usually have to resave (Save As) with a new name to get it to save. (Sometimes just using Save AS and and replacing with same name works) I have remote back up programs on pause while using Sketchup (a pain), and I’m saving to the local drive. I don’t use AVG antivirus software, but I do use Malwarebytes, however it seems ridiculous to have to turn that off in order to periodically save something I’m working on. Anyone else having this issue??

There is this topic to read through, hopefully something that was suggested will help for your case:

Thank you for your response. I had already read that thread and followed the examples. I’ve made an exception of Sketchup in both Windows Defender (or whatever they’re calling it now) and in Malwarebytes. I went back and made sure that that was the case. I’m still getting the “CFile Exception 0” when saving. It is very frustrating and annoying to have to Save AS “new name”. I don’t have this issue with any other CAD or CAM program I use. Another thing to consider, deciding if I’ll continue with SketchUp now that I’m being forced to switch to subscription.

I think I had this problem once when we were forced to “upgrade” to windows 10! And I think I solved it by turning off ‘redefine thumbnail on save’, which is found in Model Info / File. I must have then saved this setting into my templates as I don’t have to do this every time now for new files…

I could be wrong, but I think it was something like Windows 10 ‘preview pane’ meant that saving existing files onto desktop or a location that was open with preview pane on, caused that error window to pop up, as was considered ‘open’ which I think is what it does in order to display the most recent thumbnail.

Sorry if this is completely not the solution and doesn’t solve your problem, but let me know if it does !

1 Like

Thank you. I’ll give it a try and report back!

Regrettably that was not the solution. Thank you for the suggestion, it was worth a try, really thought it might work.