"CFileException 0" when saving file


#1

hi,

when i save my sketchup file i’m working on, i often get a message “CFileException 0” and the file is not saved at that instant, or it is saved with another name; filename-0
When I pause my Dropbox Sync, it works, but that can’t be the solution, because then I loose some important dropbox features like keeping older versions from saved files.

Anyone with the same problem or the answer?

thanks.


#2

Are you trying to save directly to Dropbox?

If so, that may be the issue… the preferred workflow is to save locally, and copy files to Dropbox after a local save.


#3

At least one cause for this error message has been identified. I get it reliably after I’ve sent a SketchUp model to Kerkythea for rendering. I’m only saving SKP files locally and not out to Dropbox. The SketchUp team are aware of this and have been able to reproduce that way, too. If you can identify some other event that causes it, you should report it to the team.


#4

hi Aaron,
this worked fine under Windows 8.1, the problems started after updating to
Windows 10
It still works while working in Autocad and others, only Sketchup causes
trouble.
Under 8.1 all my files were saved locally and at the same time saved to
Dropbox, so that was the preferred workflow, I want this back, help.


#5

I’m getting this error too. I’m saving locally. But I have been rendering out to Thea. I’m on Windows 7, SU 2016.


#6

I get the same error every other save when I use sketchup make on my windows 10 machine. Did not happen when I was on windows 7. Only started happening after the last (maybe 1 before that?!?) update to Sketchup make.


#8

I get this issue also and I think I found what is happening. When Office 365, Dropbox… does automatic uploads, after a file is saved to my local drive, it locks the file as read-only until it is done. In this condition Sketchup or any other program can’t save until the read-only condition is cleared. We notice it with Sketchup more than other files because they are so big.
This doesn’t solve the problem but it helps to know what is happening.


#9

I’m still getting this error in SU2017. I’m still on Win7, still saving locally.


#10

I’m also have the same issue as of today - Windows 10, SU2017, saving to desktop.


#11

I’m having the same issue. I’m using SU2016 on a pc. I think it started when I went to Windows10 about a year ago. I had so many problems with Windows10 that I’ve gone back to Windows7. I’m still having this particular problem with Windows7. Just now, I paused syncing on Dropbox as someone suggested earlier, but I still have the problem.


#12

I am also beginning to see this error message appear on workstations that are connected to an enterprise LAN. Users regularly work on .skp files stored in project folders and some will randomly get this message. As a tangent to this issue, I also have a user who in addition to this message also randomly gets a message that says his file is locked by another user when, in fact, the file is not in use. Trimble support has been less than responsive.


#13

We have a small office, new Windows 2012R2 File Server and they are getting this error message each time AutoSave kicks off. Turning off AutoSave does eliminate the errors, but is completely unacceptable to the users. I have another thread going here on our specific issue: CFileException 0 - Auto Save

The fact that there appears to be zero debugging information is disturbing. I’m truly hoping that someone can point us in the direction of how to troubleshoot this.


#14

I’m also have the same issue Windows 10, SU2017, saving to desktop


#15

Also getting this error message regularly when working with large files (approx. 50MB+) saved on Dropbox. This has been an issue consistently for us for many, many months. I can see it has been for others. Very surprised that I have been unable to find any response to this issue from Trimble.

My company is considering ditching SketchUp and moving to Revit, despite the increased cost, to enable us to work efficiently with larger files. I would rather stay with SketchUp & Layout, which suit our requirements very well in most other respects, but this single issue impacts massively on our productivity.

Trimble - please respond!


#16

I am somewhat skeptic about Revit (an application I like quite much) being better than SketchUp at saving large files directly to online storage. As matters stand today, it is more reliable to save files locally and then copy to the cloud when finished working with them.


#17

Based on replies elsewhere, I think this problem results from locking and/or temporary renaming of files done by Dropbox and similar remote file services. They do this to prevent changes while they are syncing a file over the network. I don’t think SketchUp has any control over when and whether the service decides to sync. I’m not an expert, so I don’t know whether it is possible for SketchUp to detect and do anything about this behavior.


#18

But, like others here, I am saving to the desktop and getting the error. So there’s no Dropbox sync involved. Still a mystery to me. And SketchUp too, apparently?


#19

even saving locally do you have Dropbox or another cloud service installed?


#20

Yes. Am I to understand that because the service is running, that’s affecting SketchUp? I could try stopping the Dropbox service and see if that fixes things… not that it’s a practical long-term solution.


#21

for testing purposes surely interesting if stoping the service resp. unistalling would cure the problem…