CFileException 2 when trying to save in sketchup


#1

When i try to save It pops up with this error, any suggestions?


SketchUp is not Letting me save
Why would anyone pay real money for this?
#2

What is L: drive ?
A USB stick ?
A remote server ?
Do you have permission to write to it, or the subfolder ?
Is it a slow connection ?
What is the drive that contains SketchUp.exe ? Is it C: ?
What happens if you save it onto your Desktop ?
You can always move it to its final destination when it’s complete ??


#3

L drive is my user folder on the server, I have permission to write to it. The connection is quite fast. Sketchup is located on C:. I can save it to my desktop no problem. and then move it to this folder successfully.


#4

I too am seeing this issue too. Our workflow is:
Import a few blocks from AutoCAD into Sketchup and save it on the network. Trying to save again causes the CFileException 2 error. Saving locally on the desktop is okay. The file on the network drive is renamed to a backup, .skb.
I’ve read elsewhere that this error could mean: “This error may appear if you try to use non-alphanumeric characters in a SKP file name.” - We’re not doing that.
or:
none,
generic,
fileNotFound,
badPath,
tooManyOpenFiles,
accessDenied,
invalidFile,
removeCurrentDir,
directoryFull,
badSeek,
hardIO,
sharingViolation,
lockViolation,
diskFull,
endOfFile
This is a Windows File Server which is in good operational health. I don’t think any of those issues pertain to our situation. Any help or information is appreciated.


#5

OK same error message happening to me–Have been saving successfully to Dropbox for well over a year now. Seems that a couple of issues like this may have came along following download of SU 15 pro update, though I updated almost 2 months ago, so who knows. .

Did anyone find a fix?


#6

This issue has been linked directly to Livedrive and the software component they have that affects anything saved to the L: drive. The only fix is… don’t save directly to the L: drive. I recommend this for all cloud software at this point, just to be safe… save to your Desktop or a local location on your C: drive and only copy it to your network or cloud share service at the end of the day as a backup. (To be clear, I’ve only seen this happen with Livedrive… but it’s better safe than sorry.)


#7

Hi my colleagues have this problem… I’m a CAD Monkey (for the time being!)… however I recently started work with an architect (he’s freelancing with us) and he is getting this problem when trying to save files to our cloud server platform. I believe that the server system we are using is based on the Livedrive network… although it is definitely not LiveDrive…

Saving files first to desktop and then transferring to the server is a joke… especially with frequent and regular small or minor detail revisions. It’s an massive headache and costing a fortune in wasted time - both file shuffling and inconvenience from copy / paste file naming issues! Not to mention the pfaf that results with updating layout references…

Interestingly there are hundreds of 0.skb, 1.skb, 2.skb files building in our server folders… so obviously the SU backup is working without issue.

Please sort this one out (or at least tell us how!)

Thanks.


#8

I also have this issue, I have we’re a small company of 3 but regularly need to exchange or co-work on files and cloud storage is ideal for that. But I am unable to save to ivedrive folder (L:) All access rights are ok. And Skutchup files are the ONLY ones that cannot be saved to th Livedrive storage. I would also appreciate a solution from Livedrive for this.


#9

Just ran into this problem using Dropbox folder mapped to a drive letter (in my case W:). I restarted Dropbox, but that had no effect. So, I “unmapped” the folder and then remapped it to the same - using VSubst - and that fixed the problem. I don’t know how the L:\ drive gets mapped for Live Drive, but if you can un-map it and the remap it, that should take care of the issue.

Before going to this solution, I tried saving directly to the Dropbox folder in C:\ and there was no problem. I suspect the issue is that Sketchup feels the connection is “poor” and tries to save the #.skb and then rename it.


#10

I understand saving directly to Dropbox is not the preferred method, but I have been doing this without problems for almost 2 years.

I have been getting fairly consistent CFileException 2 errors trying to save directly to Dropbox since 10-27-2016 using SU Pro 2015. Using 2016 on the same directories and same files has only reproduced this error once since the issue began.


#11

I am having the same exact issue. Using 2015 Pro.

CFileException 2 errors and 1.skb etc files generated. I have been using SketchUp and Dropbox for years with no problem…now this.

My temporary work around is to just PAUSE Dropbox sync while i am working. Then when i move on to something else, i RESUME sync. So far, no problems.

I understand this may not be possible if you are collaborating with others who need up to date files, but i am simply using DropBox to keep multiple machines synced, so it works for me.

Does anyone know if there is a thread somewhere else that addresses this that we can complain on? :wink:


#12

Pretty much the same trouble right here… I have been using Dropbox for almost 2 years, and suddenly stop to work on my desktop computer… my tablet/pc Surface Pro4 still works correctly… I will appreciate if anyone has resolve this issue to share with the SketchUp Community.

Thank you in advance and Happy New Year!


#13

The analysis given in many topics about this issue says it seems to result from slow response over the network when SketchUp saves to a non-local destination. Network response is going to vary from case to case and from time to time, even using the same computer and connection. So the fact that it worked before is not an indication it will always work.

That said, it certainly seems that SketchUp is overly sensitive to network timing. Hopefully the developers will someday get around to finding a way to reduce this problem. At the minimum it would be nice to detect that this is the cause and give a more intelligible explanation rather than the raw OS error code!


#14

… nevermind, the downgrade solution doesn’t work.


#15

Has anyone found a solution or cause of this problem yet?


#16

anyone can fix it?


#17

I have this same issue. What is the status Trimble?


#18

The fix is save locally and sync the Drop Box folder.


#19

Bebore you save, go to dropbox icon and pause sync. after that you can save the file and finally reactivate sync again. That works for me, not that I like but it doesn’t gives you the errror code CFile Exception 2…


#20

Hi, i’m having a problem with opening my sketchup file. It keeps showing CFile Exception2 then the location of the file. Is there anyway to open the file at all?