CFileException 0 when saving SketchUp files in M-Files


#1

Hi, when I open a SketchUp file stored in M-Files and try to save it back again to M-Files I get a CFileException 0 error message. I have never experienced this with other files I have in M-Files so it seems this is a problem with SketchUp and not M-Files.I have also read that some people have the same problem when saving SketchUp files in Dropbox. Do you have any solution for this or do you know when it’s going to be fixed?


#2

See if you can save to a local folder, then after closing SketchUp, sync the local folder with M-Files.


#3

Yes, that is possible, but instead of just save and close Sketchup I have to use 30 sek every time to save the file in another location, check out the file again in M-Files and replace the file.


#4

This is probably the reason why saving directly to the cloud does not work. An Internet connection is a different thing than a local drive or a local network drive. Your SketchUp models are probably larger than, say, your word processing files, so the problems become accentuated.

Anssi


#5

Yes, sounds like a network timeout issue.


#6

M-Files is a program installed on my computer and it is just syncing the files between the computer and the server. I can even go offline but still I get the same error. My models are less than 1 MB so the size of the files has nothing to do with it. Do you know what the CFileException 0 error actually means?


#7

Unfortunately, it means that no error occurred (according to Microsoft documentation!). So clearly there is some situation that causes a save failure in a way that SketchUp does not detect.


#8

I get the same error saving to my local SSD drive. Soooo, there has got to be a problem within Sketchup.


#9

I have the same problem all of a sudden. All in local C drive. Painful saving sketchup files as you have to go back & save as another name then rename to original. Any suggestions…


#10

@ronsino Are you also using M-Files ?

(And what SketchUp version are you using ? Your profile does not indicate this.)


#11

Sketchup 2016 Pro in Windows 7 and not using M-File system. All sketchup files are in the document subfolders system. This only started happening last 2 days. I did activate Trimble Connect then but have since turned it off now in the Extension menu. Still getting the message on saving.

Ronsino


#12

A new topic thread would be best then.


#13

I have the same problem. Using Make, on Windows 7. Not using M-Files just saving locally. No network. Comes up every 5 mins on autosave and when I save to exit as well.

WHAT IS WRONG WITH SKETCHUP


#14

Then you have posted in the wrong thread. Start a new thread please.