"CFileException 0" when saving file


#22

Hi, our 3 person design studio has been getting this annoying file saving error recently too. Only in the last 2-3 months from memory?

We work on a shared NAS drive (server) running 2 laptops and 1 desktop PC.

We ARE NOT saving directly to dropbox, Google Drive or any other kind of synced drive.

Can anyone provide any useful tips for sorting this problem out, or is there some kind of workaround???


#23

Hi, the only work around is patience, after months of annoying problems of
that kind, it has disappeared without any notice, I even didn’t know it.
Maybe after a Windows update our installing another program?


#24

having a cloud service installed/active might suffice already, try if uninstalling/deactivating any file based service does have an effect on this issue.


#25

I have a NAS for my backups and in my experience it has more hiccups than a properly configured Windows file server would have. I understand that generally they use some Linux clone for an OS. Of course, a full Windows network environment is overkill for a small business.


#26

the Synologys typically works well, being reluctant at least with major updates (and reading their forum before updating) helps.


#27

Are you using Dropbox or some other type of auto-backup and syncing system by chance? These systems rely on your network to move your file into their backup storage. Before making the changes, they often “lock” the target file so that no changes are made while backing up. This helps them avoid file corruption. Any latency in the process due to network speeds will cause the lock to last longer than expected and the larger the target file, the longer the wait.

Some have reported that their issue solved after they installed the latest Dropbox backup client. Others temporarily suspend the Dropbox live syncing service until they are done working and then turn it back on. You can find more info on this solution here: https://www.dropboxforum.com/t5/Syncing-and-uploads/Temporarily-pause/td-p/26224

Please note that this can happen with backup services other than Dropbox and in these cases, it is best to suspend backup services while you are working.


#28

Yes, I use Dropbox.


#29

The common advice regarding Drop Box is to not save your SketchUp files directly to it. Instead save to your local hard drive and then upload or sync to Drop Box.


#30

I am getting the same message,
I am saving to my c drive only at home and after a couple of saves of any file I get this message.
In contrasts at work we use windows 7 with SKU saving to a sever drive and we don’t have this problem.

Home computer:
Intel Core i7-5700 CPU@ 4.00 GHz
Ram 16 GB
Windows 10 Pro
64Bit processor
NVIDIA GeForce GTX 1070
Untitled


#31

VRay installed?


#32

I started getting the same error. Right after changing the default files pathway!
-h-


#33

Hi troyhome, Could you solve the problem?
I receive a “CFileException 2” error message that won’t let me save anything on my PC (no servers or Dropbox) - even with an empty blank space file!
Problems started when the trial period finished and I bought SKETCHUP PRO!


#34

I haven’t had any change to the problem. SU hasn’t made it a priority to address. So it persists.


#35

Hello Troy! So we made a little headway with regards to the CFileException 0 issue.
Normally, we see this issue related to file synch services like DropBox (though they may have fixed the issues with newer versions of the DropBox client). This was, at one time, also associated with certain versions of Podium (though this is pretty rare now). Last week we discovered another culprit… Antivirus software. In this case, specifically AVG. The user paused her Antivirus application and no longer received CFileExceptions. I believe there is a way to exclude certain folders from AVG (and other antivirus) scans. Here’s how to do it in AVG: https://support.avg.com/SupportArticleView?l=en&urlname=How-to-exclude-file-folder-or-website-from-AVG-scanning

More info will be shared here as it develops.
-guz


#36

Hello- newer member here- I recently upgraded and purchased SketchUp Pro 2018 and I have been having this CFileException 0 when saving as well, however I am NOT using DropBox or AVG, however I am using the Avast free antivirus.

Temporarily completely disabling my antivirus will allow me to save without this error, however I was wondering if there was a workaround similar to with AVG, however I haven’t been able to figure out how to exclude a locally saved Sketchup Folder directory with Avast the way AVG has.


#37

#38

Thanks everyone. I have been having this same problem since uploading 2018 version earlier this year. Thanks to all of you when I turn off Webroot Antivirus software, then Sketchup auto-save runs without that darn warning. Plus it seems to work just as well with a manual save.

Now I just have to remember to turn Webroot back on after every session!


#39

Can you whitelist Sketchup 2018 inside your webroot antivirus?


#40

Our IT consultants did just that, we haven’t had any problems since.


#41

guys you have to save it from another destination folders i hope this is works and its worked for me