File exception error

Hi,
while i’m working with sketchup i see the error message:
CFileException 0 in c:\temp\test.skp
Then i have to save and sometime i lose the whole file.
How to resolve this problem?
Thank you

What version of SketchUp are you using? Your profile indicates you are using the free web version. Is that correct?

It looks like you are saving into a temporary folder. Is that where you have saved the file? If not, where have you saved it?

Sketchup pro 2020
20.1.229 64 bits
i save the file in my local disk in c:\temp

Please correct your profile.

What about where you are saving the file? You should not be saving files into a Temp folder. That’s a guaranteed way to lose the file.

When you installed SketchUp did you right click on the downloaded installer and select Run as administrator?

i did not run as admin when installing.
ok i already tried to change the folder from temp to another but i noticed the same problem.

You should. Close SketchUp and find the downloaded installer. Actually, you might as well download the latest version of SU2020 since you are a version behind. sketchup.com/download/all Right click on the downloaded installer and choose Run as administrator.

Restart your computer and try doing some modeling. Make sure when you save the file you aren’t saving it in a temporary location.

Will i lose all my extensions if i follow your instruction ?

No. The extensions won’t be affected.

ok now it looks working.
thank you

So proper installation took care of it? Perhaps you should mark my post suggesting that as the solution so others who might come along with the same problem can figure out what is the solution.

I did

You marked the wrong post as the solution.

It should have been Dave’s post #6

Again i see the same error message File exception and then i have to save several times.

I installed SU 2021 on Windows 64 and got CFile exception 2 when I tried to save a model. For me, the solution is barking mad but simple and quick and may apply to others. So here’s how I solve the problem.

Open the parent folder for the folder you are trying to save to. Set the view to “Large icons” or “Extra Large Icons”. Does the problem folder have a black background like the one in the picture below? If so, read on.
image

Right click the problem folder with the black background and select Properties > Customise > Change Icon… > Cancel. Then click OK (not Cancel) to exit Properties. (Yes, really. We’re doing precisely nothing.)

The black background will disappear and you can now save your Sketchup files to that folder.

Easy peasy lemon squeezy.

Weird. What do you suppose gives the icon the black background and how would that affect saving to it?

I think it’s an ancient Microsoft relic gone haywire that’s been kicking around for years related to files downloaded from a insecure source - i.e. the internet. At one time, you’d get a warning message in Properties if you knew to look for it. It’s really quite appalling.

For completeness, the black background folder business worked for a while, then stopped working later. Here’s my second effort. Check Notifications for “Unauthorised changes blocked” and follow the links.

Or.

Go to Settings > Update & Security > Windows Security > Virus & threat protection > and click on the “Protection history” link under “Current threats”. Here you can see which applications have been blocked by “Controlled folder access” and follow links to “Allow an app through controlled folder access”.

Interestingly, Sketchup 2017 was already in my short list of allowed apps. It’s happened before, but I just forgot about it.

So far so good. :grimacing:

1 Like

Thank you so much for updating this! Wow. So simple, just did not occur to me.

1 Like