"File currently locked by another user" error in Windows Explorer

We have found a bug that has a workaround. The “file currently locked by another user” message seen when the preview pane in windows explorer is open and the file is opened by double clicking. Some people get a “read only” version when opening.

To see the issue, you need to have the Preview pane open (which is turned off by default - which is a good thing - on Win 7, Win 8 and Win 10), Windows Explorer needs to be set to a thumbnail view, the model needs to have a thumbnail and the user needs to double click on the model to open it. Therefore, please make sure the preview plane is unchecked or closed as Step #1 of the workaround. See below.

Workarounds include Step #1 turning off the Preview pane, Step #2 setting Explorer to use a non-thumbnail view (see below), Step #3 closing the model and double clicking on it a second time or opening models via File > Open.

  • It appears to be an M3 regression
  • It seems to be isolated to Win 7 - Although may occur on the Win 8 and Win 10
  • If you see the issue, close the model and then double click on the model again, the issue can not be reproduced.
  • When the issue does occur, the user can open the model, but it truly will be opened with a read only status

@AlexB what happens if you allow the ‘read only’ file open, then from the ‘File’ menu ‘Close’, then ‘Open Recent’ >> select that file?

I’m on a mac but curious…


I appreciate you wanting to help but, this is a very specific bug that only occurs when the preview pane in windows explorer is open and the file is opened by double clicking. Any other process (clicking open from within SketchUp, turning off Preview Plane, or similar to what you suggested) will not replicate the bug, again, because it only happens when the preview plane is open.

Thanks for your suggestion however, Mac and Windows workflow is very different and to make Mac suggestion to a Windows problem can tend to get confusing as the options are different as well as what they are called and where they are located (if at all)…etc. p.s. I personally am a Mac person too :wink: but shhhhh don’t tell the engineers!!


I have run into this artifact over the years with programs other than SU and Windows earlier than widows 7. This has also been discussed in some of the Sytem Internals posted by Mark Russinovich. The windows memory manager is basically a demand function and when a program ask for memory ( Programs cannot touch real memory but only virtual memory.) it is quick to assign some memory in 4 k blocks what is called working group. When the program is closed it releases that at a much slower pace. So if you close a program and then try to immediately open it you will get this error.
I cannot say if your issue is same or why W8 and up don’t have problem maybe just the fact MS has made changes in memory manager so it does not show up.
Just more triva for you

1 Like

Thank you for your input @mac7595.

another workaround would be using the free LockHunter… but don’t try this at home if you don’t savvy what you’re doing :wink:

For what it’s worth, if you weren’t aware, this problem only surfaced with the latest release of SketchUp. Not a problem with 15.2.685, problem with 15.3.331. Confirmed with multiple systems with same Windows patches, just different SketchUp versions. Perhaps that will help you identify what change introduced the problem.

Either way, also note that you need to disable both the Preview Pane AND the Details Pane (found in the same interface mentioned above) to release the lock on the file. With both of these disabled, everything works properly.

This looks to be Layout problem, not Sketchup, correct?

No - is definitely an issue for us with Sketchup (we barely use Layout).

Sorry, I misread. I had tried that previously, and yes, turning off Windows (7) previews is a work around, but a pretty crappy one. I actually use previews. So, this isn’t an option. Thanks for the prompt reply.

I just had this bug occur using Windows 8.1.

The model created backup files numbered 1, 2, 3, 4. Then when I tried to save the file it would only create backups and not update the current open master file.

I was able to open the file using the workaround and then save the latest backup to the master file name, so all looks good now.

Firstly, the “Preview Pane” was never open in the Windows Explorer on the Windows 8.1 PC in question. However, I do have “Thumbnails” displayed. This is a Sketchup issue; not Layout (I have not as yet used Layout). This has happened more then once, but it only seems to happen if I open multiple instances of SketchUp. I have never experienced this problem with multiple instances of other programs. Again, what appeared to have cleared up the problem was terminating one of the COM-Surrogates that were running. Attempts to terminate any of the remaining COM-Surrogates are protected and blocked by the system. The issue appears to be the orphaned COM-Surrogate.

This here is a duplicate issue

Is this something that will/can be fixed? If I can’t use the preview pane and the thumbnail view, it really defeats the purpose of thumbnails preview.

I had this issue as well. solved just by closing the preview pane.
this is quite essential to any sketchup 2015 users as thumbnail view was finally implemented.

Using SketchUp installed on Windows 8.1 64-bit PC:
I have had files/folders LOCKed by SketchUp-make after Exit; without the Preview-Pane being active. I have traced the problem to SketchUp failing to properly release a COM-Surrogate upon Exit. After manually deleting the COM-Surrogate in the Task-Manager, the files and/or folders were unlocked.

Just for the record I am back to 685 because of the same issue.
It is obviously a SU bug. Mine did release by itself but at the speed of a turtle.


I tried following your instructions without luck. I’m using Win 8.1, 64 Bit with SU Pro 2015 (ver 15.3.331) which I just bought yesterday. Windows explorer for 8.1 has a different menu structure from what you have shown; but, I’m quite sure that I have the preview pane turned off (not highlighted). The files are definitely set to show details only. I can’t find a way – either by double clicking on the file in Win explorer or using “file - open” in SU that will present me with a file which is not read only. This is a major obstacle. Have you any other thoughts about how to deal with this?

Sorry to hear you are running into problems! I am looking into this for you and I want to get you back up and running asap.

Thank you,


I have been unable to reproduce this problem in the lab. Since I can’t see this happen, I am hoping this is a rare state you have gotten your machine into. Here are two steps for correcting the problem.

  1. I am about 80% sure this is what you are hitting. Above in this thread there is the issue mentioned about SketchUp not releasing a COM-Surrogate object. Have the user go into task manager, show “More Details” and kill the background progress “COM-Surrogate”. See if this resolves the issue.

  2. If step #1 didn’t do it for you, you can reboot the machine to force whatever program is holding the file to release it.

We are working to resolve issue #1 so it won’t be a problem in the future. Please let me know if this helped.


1 Like

Based on some comments I read in another thread after putting up my post, I attempted to open the offending file without luck. Then, without closing SketchUp or taking any other action, I did another “file/open” sequence and it came up OK. I have gone through my earlier files from SketchUp Make and found that SketchUp Pro 2015 is opening them without incident. With luck, the problem is solved. Thanks for your feed-back, Geoffrey.