File Lock Issue


#1

When I tried to open a second SketchUp file in another instance of SketchUp, a notification pops-up stating that the file was already open by another user, do I want to open it as read-only.
Since the second file was not opened before and I’m the only user on the PC something was wrong. After having closed all Apps, I tried again, but got the same message. However, when I tried to open another SketchUp file I got a different message; the file was in use by a “COM Surrogate”. In the Task-Manager there were three Com-Surrogates running; I ended one and was then able to open both the “Locked” file and the other messaging about the COM-Surrogate. It appears that SketchUp may not be terminating properly in certain instances; leaving hooks.


#2

Might be related to this thread.


#3

Firstly, the “Preview Pane” was never open in the Windows Explorer on the Windows 8.1 PC in question. However, I do have “Thumbnails” displayed. This has happened more then once, but it only seems to happen if I open multiple instances of SketchUp. I have never experienced this problem with multiple instances of other programs. Again, what appeared to have cleared up the problem was terminating one of the COM-Surrogates that were running. Attempts to terminate any of the remaining COM-Surrogates are protected and blocked by the system. The issue appears to be the orphaned COM-Surrogate. My work around is to kill the orphaned COM-Surrogate.


#4

Firstly I said might.


#5

Sorry, didn’t mean to sound critical. I did appreciate your response. I hope the developers read this thread, as it may give them a clue to a solution.