"file currently locked by another user"

suddenly about 3/4 of my saved drawings ar giving a message: “file currently locked by another user”… there is no other user. I read the 5 “topic is similar to” entries. no help, extreme no help. so, why the (bad words) did this happen all of a sudden?

Which version of SketchUp Make are you using? This issue pops up quite often. Normally Administrator privileges or killing the COM Surrogate from the Taskbar fixes the problem for me.

Basically this is a Windows problem that is not particular to SketchUp. At work I get it very often with files and folders on network drives. For instance, opening and closing a Word file and trying to delete it shortly after that will produce this error. It can take a long time or require Explorer to be restarted for Windows t release the file.


Following this post

How do we “kill” or get rid of the COM Surrogate from the taskbar?
Thank you in advance.

Open up Task Manager by right-clicking on the taskbar. Under the “Processes” tab locate COM Surrogate, right click on it and choose “End Process”. I have to say though, killing COM Surrogate may cause some problems with the system, at least that’s what Google brings up. I personally never experienced problems.

I have no idea what any of this means… COM surrogate? windows eliminated
the task bar (or so I was told when I had Vista). this has never happened
to any of my files in other programs . just in SketchUp. for once I would
like to have an upgrade that didn’t require a whole college level course to
use all of it well.
Windows help tells me that windows 10 doesn’t have this problem. I never
had this problem before windows 10 and only just now after months of using

In my case the cause may be that I save my Sketchup SKP files to a Windows directory that is mapped to Google Drive.

Since the SKP is quite large it can take Google Drive sync process several minutes to replicate it to Google’s servers - during which time the file is locked via Windows.

That’s makes sense - so I can ignore the “locked by another user” warning when opening

But when I later come to save the SKP file under its original name SketchUp tries to be too clever, saying “It was opened as Read Only”, and refuses to let it be saved back, even though by now GoogleDriveSync has released the Windows lock by then.

It’s fine to have a warning - but please could we have the option to override it & save the file under its original name?

This issue is such a beating. I also save to Google Drive, like Chris Lambert mentioned and I don’t know if that is causing the issue. I have tried all the fixes and workarounds mentioned here and every other thread I could find, and haven’t found anything that solves the issue.

Every day when I first turn on the computer, I immediately try to open whatever file I’m working on. I have tried opening from explorer, from within a fresh sketchup session, and from the start menu, all with the same result. 90% of the time it is locked. 10% of the time it opens fine. I can either spend an hour going thru all of the “fixes” that don’t work, or open read-only. Saveas something else. Close. Delete the original file. Rename the saveas file. Then open that one fresh. Even after all that, the file is often still locked.

I would really appreciate any help.

Thank You.

I think I may have just figured out my issue. I have two google accounts, a personal one and a business one. If I am not logged into my work google, then files in that drive are read-only. Seems logical, but didn’t occur to me before. Which is why doing a “clean open” of a freshly started PC doesn’t work. I guess the PC defaults to my personal google login instead of my business login. I guess my lesson here is to check (google) email before starting real work.

1 Like

I believe this is a Windows 10 problem, related to Volume Shadow Copy (or Service) VSS. My limited understanding is that when a backup occurs, VSS makes a copy of the file to backup while allowing the user to continue to access the file. For some reason, Win10 (on my machine at least) keeps stopping VSS.

To fix, open Task Manager, click Services tab, scroll down to VSS and check the status. If it says “Stopped”, right click and select “Start”. It still takes a while for Win to release the file again, but once it does I’m usually good for at least a day or 2. Real PITA! Gotta love microsoft…

Just so people know, if you search the web you will find that a) this problem isn’t specific to SketchUp, there are lots of reports of it happening with Microsoft Office apps too, and b) it isn’t specific to Windows 10, it has been happening since at least Windows 7. I’m not a Windows expert, but the reports seem to say it is somehow related to Windows not removing a “owner file” it creates on the remote disk in a timely fashion.

This problem orginally came up and was claimed to be related how the widows memory manager works. I do not remember which sku version of widows.
The memory manager is a demand type system. When a app is started it request memory form the OS and it (OS) then allocates memory in blocks called working set. It does not allocate all that is requested usually because some apps share memory although some " bad" programs will try to hog memory by requesting large chunks of private memory.
To make a long story short when a app is closed the memory manager does not immediately release memory and is the reason the error was thrown if one tried to re-open app quickly.
It looks link the original problem is now morphed into larger problem.
There is a snap in you can load a run a see what programs are requesting and OS allocating in terms of memory

Personally I encountered this error if I used Vray as my Render engine, but If I use the render i didn’t get this issue.