Why does SU think the file is open?


#1

SU pro 15.0.9350
W7 x64
16gb ram

When I open an SKP file SU will tell me that it is already open.
If I say I don’t want to open in read only mode and try to open again it will open - sometimes it takes 4-5 trys.
Obviously, it is not already open. This happens 99% of the time.


#2

Bill, why have you not updated to v 15.3 ?


#3

Have a look at this thread


#4

I have never used the preview pane in WE
using detail view.
first noticed this bug in 15.3 of Make.
had to go back to 15.2 cause it was so annoying.
So why does 15.0 of pro have it?
and why wouldn’t 15.3 of pro have it if 15.3 of Make does?


#5

It may be a bitness bug. Are you talking about all 64-bit editions ?


#6

yes both were 64 bit
OK, what is a “bitness” bug???


#7

A bug that occurs only on the edition compiled for a particular OS bitness.

Some users with certain Graphics cards, have had to uninstall the 64-bit SketchUp edition, and run the 32-bit edition. There is some issue with OpenGL and 64-bit function calls with their graphics cards.

(And I do not know what yours is, because you have not filled out the 3 IT questions in your profile.)


#8

GTX560Ti on W7 x64
Why does a graphics issue cause the program to think the file is already open???
Seems like disconnected functions to me.
Why does it do it 2-3-4 times then be happy???
Sounds like a race condition in the software to me.

But then what do I know.


#9

I did not say that.

I just used that issue as an example of a bug that we know is occurring on the 64-bit builds, and not on the 32-bit builds.

(And added the offhand comment that you hadn’t filled out the 3 IT questions in your profile.)


#10

With regard to the “ThumbsUp.dll” … you could try a simple test, by renaming it, and reboot (since this is an Explorer bug,) and restart SketchUp. Then retry…

This was suggested by SketchUp Team member Jody here:

If this does not work you could try one of the 32-bit editions.


#11

thx I will try that
the curious thing is that it does not happen with 15.2


#12

Yea, in that thread Thomas suggested it was a regression with the M3 build.


#13

I poked around in the Microsoft forums and found a post that gave instructions for “taking ownership” of files and folders. This was in a thread about not being able to access files and folders even with Admin rights.

It got me thinking, and I went and checked files that I wrote myself both in my “Documents” path and in the “Public/Pictures” path.
The ones in my User path, the owner is set as the "Administrators Group"
The ones I wrote to the Public Pictures path, as set as “NETWORK SERVICE” being the owner.

So where are the files that you have issues with ?
Public path or User path ?
Local path or Network path ?


#14

And I found another post that says file locking occurs on Win7 also with the Details pane and Popup file tooltips active. (It is in the Microsoft Excel Support Team blog. The item was posted 3 years ago.)

ALL 3 need to be turned OFF:
Apparently as you are double-clicking to open the file, Explorer is trying to read information about the file, to display in the Details, or popup tooltips.

[quote]III. Turn off the Preview Pane, Details Pane and pop ups that show information about file and desktop items

This is a problem that has been reported to affect Windows 7 clients only, not Windows XP. The problem here may have something to do with the Windows Explorer in Windows 7. We are currently investigating this further and will post more information as it is available.

In a Windows Explorer window, do the following:

  1. Right click on the Start Button.
  2. Click ‘Open Windows Explorer’.
  3. At the top left click Organize > Layout
  4. Uncheck Details Pane and Preview Pane.
  5. On a Windows menu, click on Tools > Folder Options. In the box that opens up, click on the View tab. Scroll down the list to “Show pop-up description for folder and desktop items” and clear the checkbox and then click OK.
    [/quote]

Problem with Open/File in SketchUp 2015
#15

thx
i never have used the preview pane but on my laptop the detail pane is checked so it must be checked on the desktop.i will chk that later.

I guess i must question why sketchup is the only program that has an issue with this


#16

It must not be if the MS Excel Support Team is saying it happens when xls files are double-clicked also.

I never have the issue because I don’t open models that way. I open SketchUp first.


#17

I have never had it happen with Excel. I use office 10 and xlsx files


#18

Well I do have a protocol I follow whenever the File Explorer listings fall behind.
I click in the list pane, click the F5 (Refresh) key, then click the tree pane and again click the F5 key.

Next time you get the “file locked” dialog, you can try this, before another double-click attempt.


And you don’t have any problems using the right-click menu > “Open with SketchUp 2015” ?


#19

OK, just chkd. It is explorer related. If I clk the file on my desktop it seems to work.
If I clk when I first open explorer it seems to work. If I move around in folders then clk it bombs.
If I rename thumbsup.dll it also seems to work
I didn’t do much testing but it looks good so far.
But I do the same thing with an xlsx file and it never happens. So, why can’t SU be fixed.
I have no idea what thumbsup is for so maybe I won’t miss it.
But if renaming it solves the problem then would one assume fixing thumbsup would be the thing to do?


#20

It was fixed in M2, but someone (possibly) broke it again fixing something else for M3.

“ThumbsUp.dll” is the SKP file Thumbnail image handler for Explorer. It is called by explorer.exe to display little bitty images of SketchUp models in the filelist pane of Explorer.


One thing I we have not tried, is to copy the 2015 M2 “ThumbsUp.dll” file into an 2015 M3 install.