SketchUp 2015 64-bit - All files Read Only

I just installed the newest version of SketchUp 2015. It appears the bug fix regarding thumnbails and windows explorer crashing has been fixed. However, there is now a new issue with all the SketchUp files being read only. I know that this is the new version causing this, because the last release did not have this problem. Anyone else having this issue? Are there any known fixes?

You mean the binary program files or the data (model) files?

How did you ascertain that they are Read Only? Did you find the Read Only attribute set on the files at the operating system level using Explorer? When you try to open a file in SU 2015, any chance it’s already running in SU 2014?

-Gully

What I noticed just a minute ago is, when you have windows 7 set to show thumbnail previews of the SU files, once executing the file from a project folder, the file comes up saying that the file is already open, “would you like to open the file read-only”. Once I disabled the thumbnail previews using the Windows 7 folder options, this is no longer happening. It appears there is still a problem with thumbnails.

Opening the file directly from Sketchup 2015 does not cause this to happen. It is only when executing the file from windows explorer. No, the file is not open in any other versions of SketchUp.

I think it is a common Windows problem. I often encounter it with diverse files when cleaning up my folders, not only SketchUp. I check what is inside a file, close the application and then try to delete the file or folder. Result: error message about file being in use or read-only, and sometimes only a system restart will fix it, sometimes closing the wholefolder tree will refresh the info.

Anssi

This happens anytime I open files using Windows Explorer and the preview pane is visible.
I need to either close the preview pane or close the folder and open using Sketchup open dialog.

Dodorama- I concur. I have the same problem and by disabling the preview pane, the read-only error stops when double clicking on a file.

I am running Windows 7 Professional, Sketchup 2015 Pro. Have the same issue. When I turn the preview pane off, in Explorer, the issue is resolved. I don’t see this as a “fix”, however, since the preview pane is important to me… Any ideas of an actual fix for this? Considering it was not an issue in the last 10 years I’ve used Sketchup, I don’t understand why it is suddenly occurring with the latest version.

1 Like

Have you checked out this post? Maybe that workaround will solve this issue as well. Some people experienced read only files as well.

I’ve installed version 15.3.331 64-bit for Windows and also noticed that whenever I open a file for the first time I get this message more than 90% of the time:

I say ‘No’, reopen the model and this time it opens without any issues.

I have Windows 7 Professional 64-bit Service Pack1 with all updates.

I don’t have windows preview pane open!

I have the same problem without windows preview.

Same problem here, at work and at home. IT guy created a kill comm surrogate action for my work pc which disabled the preview pane but I also need that turned on when browsing certain files so it was all in vein.

Same problem with thumbnail…

You can’t just turn off the Windows preview pane, you also have to turn off all file previews in folder settings. The complete workaround is to open a file directly from the sketchup interface. This is problematic for people because sketchup does not remember your folder location upon opening the program, nor does it have shortcuts you can add for file browsing like autocad/revit. For me, that would be the easiest fix, and very useful.

Is everyone by chance running Windows 7? Or are others with Windows 8 and 10 have this same issue?

have you set your File location preferences?

I do, but this is only useful if you work locally. I work on multiple projects for a large firm, which means lots of folder navigation. So setting a default location doesn’t really work.

I find it absolutely ridiculous that this issue was discovered back in February, and it still exists.

I have turned off Preview and all the other work arounds here:
http://help.sketchup.com/en/article/3000178

It appears that the hang-up is related to opening the file too quickly. If I open the file and pause 5-10 seconds before clicking the button that says “Start using Sketchup”, it opens fine, otherwise if I click it immediately I get the read-only error - every single time.

issue STILL exists in Sketchup 2016 AS WELL

Upgrade to Windows 10. This resolved my issue.

I HAVE A MASSIVE PROBLEM WHEN I OPENED SKETCHUP IT ASKED ME SOMETHING THEN I ACCIDENTLY CLICKED READ-ONLY THEN I DID A BUNCH OF WORK ON IT THEN I COULDN’T SAVE IT BECAUSE OF READ ONLY, HELP!!!

Can you do a Save As?