Faces not forming - fixed!

Hi all,

I imported a DWG into SketchUp, cleaned it up using a few extensions, but I’m still struggling with one particular area in the drawing. A couple of things that are confusing me:

Image 1 - this section of geometry wont form a face (no gaps, all lines touching, no stray edges, all should be co-planer as I ran Drop Vertices to 0). I’ve zoomed in as far as I can in all areas and cant see anything amiss.

Image 2 - I am getting that weird shiny face thing that happens when you have a group on top of a group in certain areas of the image, but only from certain angles. Maybe this is a graphics card issue or is there something else going on?

I run into issues like these often and they are so frustrating and eat up so much time. Any advice/explanation would be very much appreciated.

Thanks so much

104_Cottenham House_Masterplan import.skp (854.6 KB)

correction: The upload when in the wrong order so image 1 and 2 are swapped. I also uploaded the actual file

Thanks in advance to anyone who can shed some light on this. I am completely baffled!

Forms a face when you erase the intruding edges.

Screen Shot 2021-01-19 at 12.58.14

You can also just left-select to highlight the original geo, and right-click Intersect Faces with Selection to force the current edges to recognize their meeting points.

As for the cloud, I’m not sure anything’s wrong with the geo or your GPU. I think the extreme mess with groups and tags that is still present in the file is making for weird face display behavior.


you have raw geometry that is tagged. No raw geometry should be on anything but “untagged” tag. That may explain why you have z-figthing in your first image. to quickly fix it, you can select all tags but the untagged one, delete them, move content to default layer when it promps, select all and intersect.

you also have groups / components that cause Z-fighting

104_Cottenham House (SU2017).skp (1.2 MB)
Much more attention should be paid to how such a plan is drawn in Autocad.

Thats really weird as when I do that, it doesn’t work! My file is uploaded again with the intruding edges erased 104_Cottenham House_Masterplan import.skp (835.0 KB)

What have I done wrong :frowning:

I tried that but I couldn’t get it to work. Again, I must be doing something slightly wrong!

@paul.millet. I didn’t realise having raw geometry tagged was a bad thing, thanks. I just tried deleted all the tags and forcing everything on untagged but that hasn’t made a difference sadly

The glitchy area doesnt have any groups or components in it as far as I know

@mihai - my boss drew it and I have no control over the way she draws :frowning:

Your second upload still has the intruding edges - not the ones you erased, but the ones which are extensions of the shape’s defining edges, which you can see are erased in my first photo.

Intersect faces stopped working after your edits. It works consistently on my SketchUp in the original file.

Screen Shot 2021-01-19 at 13.19.25

did you select all > right click > intersect > intersect with model after doing so ?

Did you see the file I uploaded - 104_Cottenham House (SU2017).skp in the previous post? Is that what you wanted?

The plan has many lines very close to each other, you will probably have to choose what to keep and what to eliminate to make your work easier.

I’ve taken into account all the advice above - thanks very much - but still can’t get this completely clean.
Like Mihai says, perhaps the DWG is just too badly drawn to begin with as when I manage to fix part of the geometry, other parts glitch up. In case anyone is kind enough to keep helping, I recorded my attempts in the videos attached (via dropbox as files are huge)

I’ve also attached the DWG file.

Thanks again very much to all who have helped.


(upload://VSqlmLCkSQ3omFaQx2gZ9ggy0Y.dwg) (86.9 KB)

Landscape.dwg (86.9 KB)

not sure the DWG upload worked so here it is

I didn’t see you intersecting all in your video ! See my previous post

I did that in the second video. It worked for part of the geometry but then other parts didn’t work

@joanarze, you still didn’t open the file I sent you 10 hours ago?

Isn’t that what you want?