Sketchup not generating faces correctly from CAD files

I have just upgraded from Sketchup 2020 to 2022. Almost immediately I am noticing that when I am trying to use the push-pull tool to extrude imported DWG CAD drawn building profiles, Sketchup is now having an EXTREMELY difficult time in doing so.

Everything is CAD drawn and imported as a DWG, so all is perfectly square etc, yet I am forced to piecemeal the faces together with LOTS of triangles just to get a simple closed face. Normally this only occurs if and when there are small discrepancies, like unequal dimensions or with lines that are not perfectly parralel to each other.

Now it is occuring on nearly every single object I am trying to extrude that is coming in from CAD. It is causing me no end of frustration and I am getting quite angry about it. Definitely a BUG. I’ve been using Sketchup Pro for many years, and the 2022 version the first version that is giving me these horrific issues.

My productivity with Sketchup has totally tanked because of this!!!

Anyone else experiencing these unbelievably annoying issues???..

There was a change in version 2021 with the new file format. Sketchup is now less tolerant of small errors.

Honestly I stopped trying to do this years ago. Just bring the DWG in and use it as a reference. Set it on it’s own Tag and just trace over it. Good luck.

Wow, really??

Could you expand a little on that for me? From the outside it seems like one of the most foolish things you could possibly do for a piece of software that is entirely built on surface modeling!! Now they make it even harder???

I can’t be the only one suffering from this seemingly insane ‘upgrade’.

Any talk about reverting to the desired functionality of old? If not, I’ll be dumping SU 2022 immediately and reinstalling SU 2020.

How stupid can Trimble be??..

The first release of 2021.0 was tough on small geometry. That got adjust over time, and if you’re using the latest 2022.0.1 version some of those earlier issues are gone.

It would be interesting to see an example file, that when imported leaves some empty faces.

Interesting - in a bad way.

I installed SU 2022 2 weeks ago and have been going out of my mind with the phenomenal amount of issues I’m having with ‘simple’ surface generation.

Compared to SU 2020 there is simply no comparison. Even that had some issues, but comparitively, 2022 has taken a MASSIVE step backwards in terms of functionality and useability.

I’m not talking so much about surfaces on the XY plane (although these are definitely an issue as well), rather on surfaces trying to be generated in the ZX and ZY planes in 3D. I use the tape measure guides as a matter of course to ensure my geometry is parallel and square, yet the issues I get in generating faces are utterly horrific.

A lot of my work is generating large context models for big architecture projects. As such a CAD drawing is used as the base to built up the model. The context buildings that I have to build cause the biggest issues of all.
Pulling them up in 3D is fine, but as soon as I try to modify / extend / reduce the volume in any way, that is where the horrific issues in SU 2022 blatantly slap you in the face.

I have included the CAD file that I have used as the base for my 3D model.

If I may ask, why have you done this to SU???..

SU_surveybase.dwg (1.3 MB)

One more thing, can you sell a full copy of SU 2020? I’m not interested in using SU 2022 at all. It’s junk.

You have a subscription, you can use 2019, 2020, 2021, or 2022. 2020 and 2021 can be downloaded here:

2017 is there too, but we don’t sell a permanent license for SketchUp anymore.

I tried your example DWG in 2022 and in 2017. Neither of them make faces automatically. The import in 2017 seems faster, I will try to find out why that is.

This extension will create faces in both versions of SketchUp:

You might also find this extension helpful:


Really all I want is to be able to use sketchup as a reliable, stable and functional surface modeler. v2022 is soooooooo far from achieving that…

Thanks for taking a look.

I mostly separate the relevant linework onto separate layers in CAD prior to exporting. Makes things a lot easier to find and navigate once inside SU. Everything but the buildings are simply ‘Draped’ onto the contoured terrain using the sandbox tools.

The real issue comes in when trying to modify the buildings. Making pull-outs and roof lines etc not seen when tracing over the buildings in CAD, and cleaned up with the help og google street view. That is where the headache of surface generation in SU 2022 becomes glaringly obvious.

Could be an issue with the DWG translation, because all these tiny misalignment issues such as not being perpendicular or parallel come into effect. I know SU hates this, but never before has it been so incredibly painful to navigate as in SU 2022…

Pulling up the 2D building outlines works fine as you say. I’m not sure it’s totally evident if you haven’t worked with earlier versions of SU doing the same type of modeling.

For me, these issues are a deal breaker for me in 2022. Never before has it been this bad, nor this painful to manually correct.
As stated by COLIN earlier, these issues came in with SU 2021, and have mostly remained ever since. It makes adding in lines or trying to close and manipulate geometry once pulled up into 3D very difficult.

I think a good solution is if SU could auto-correct misaligned profiles that are not ‘perfect’ in terms of being perpendicular or parallel. Is there an extension for that?..

ThomThom’s EdgeTools might be a helpful:

Suite of tools for working with edges.
[. . .]
Close small gaps - useful for importing DWG drawings where edges doesn’t quite line up. Gives you a visual map of where there are edges with open ends and offer solutions for closing them with one click.

This is a great extension, I use it as well. Sadly it does not incorporate correcting 2Dprofiles that do not have totally perpendicular or parallel lines. So for the moment I am stuck having to check and correct all these misalignments manually… Argh.

Sketchup’s over sensivity to this ever since the changes brought in with v2021 make doing this mighty painful!! :slight_smile:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.