Triangles on surfaces after exporting DWG


So I’m having problems exporting a 3d model dwg. Which is then being opened by a CAD software.

Before I got a new MacBook and at the same time went from 2019 sketch up to 2023, this issue wasn’t happening. I would export each panel as a dwg and send it off to be cnc’d. The cnc person would open the file no problem.

I’m not sure if those changes have affected something but now when I export, the cnc person gets a ‘drawing file requires recovery message’ and then when it’s open there are triangles on the surfaces of the model.

I have imported the new files since changing and the old files into both 2019 and 2023. They import back into sketch up as a group, when I explode them, the surfaces are in multiple odd triangle shapes. I havnt tried to do this on my old laptop yet but it seems odd that a new laptop would be the issue. So I’m
Unsure if that import and explode would have happened before or even if that’s the issue. Maybe it’s something simple that isn’t checked on the new laptop but any help would be greatly appreciated!!

Thanks you!

Worth noting, before I export I dont make it into a group.

Here is a picture of the panel after importing the dwg back into sketch up and exploding it

yup, pretty standard.

sketchup works with vertices and faces. if you’re a computer, and you try to make a face, the simplest method is a triangle. it’s always a face, even if something moves.

So 3d softwares triangulate stuff.

Off course, if you design an element in SU, you won’t see the triangles, as long as your design remains flat. however, by exporting it to another file format, it’s possible the faces will be cut into triangles, in order to maintain the global aspect of the complex geometry. and when you take it back into SU, the lines are here.

it’s technically just cosmetics, you can erase the lines, since the faces are coplanar, it’s ok.

To tell you more, we’d need one of the files (you can drag it here in the answer window, or through wetransfer/other) to rule out geometry and other issues. could be that your model is more complex than it used to , could be a change in the dwg translator, could be… many things :slight_smile:

My guess would either be the export was slightly off axis, or there is a small error in the original geometry.
Seeing the original .skp file would help.


one right x 1.dwg (883.8 KB)

Here is an example…

But what is weird is that, I have sent hundreds of files like this before and have never had an issue, it wasnt until the last two patches / jobs where there has been this issue. and its not with just one file. I normally send up to 30 files like this. they all have the same issue… but I’m doing nothing different from before.

Please upload the Sketchup file used to create this DWG. There are circles of edges (highlighted in red) that could definitely cause this problem because they define faces that are too small for the software to process properly.

Basically when I export, I take the panel / part from a file with loads of other parts and panels. I put it in a blank template and never save that file. But I’ll save that now for you to see the orginal model.

The odd thing is this wasnt happening before, to any of my exports. which would be the same as these.

Thanks so much!
Panel for forum.skp (84.8 KB)

yeah, weird stuff, it looks as if a second circle appeared on top of the first one.

could it be that the conversion to dwg transformed the original circle to a regular circle (not a polygon), then reopening in SU re-transformed it into a SU circle ?
deleting one of the line causes the circles to close up, so I’m gonna point in that direction. circles. SU’s nemesis.

I even did a test with the circles exploded, and another with the circles as polygons, didn’t help :confused:

also, I spotted 2 things but they didn’t help. but still :

when exporting, by default it’ll export in autocad 14. autocad 14 was released in 1999. SU23 can export up to autocad 2018. I’ve had issues solved by this once or twice, as long as the other guy can open a newer version, no need to go 24 years in the past.

and you have a tiny speck inside your volume. I had hopes that it was causing the issue, but nah.

have you tried an older file ? one that was ok before, to see if it does the same ? il would at least indicate if it’s a version issue (dwg translator) or a file issue (your specific design sends SU in the nuthouse)

Thanks so much for doing all of that!

So I went onto my old laptop as well and opened a file which my cnc person hasnt had problems with before and it does it exact same thing, so that indicates its to do with the 2023 software and a compatibility issue with the new software i’m using with his software… right!?

My models / files aren’t exactly complicated and the way I drawer, the type of file it is and how export it hasn’t changed, so must be 2023 SU?

Cnc person said its better when I export to 2018 cad but still not like it was before.

Then is there anything I can do to fix this?


ok, we might try a thing.

take this file, the one with a problem, and export it to sketchup 2019 (save as, and choose the right vintage)

open it on your old laptop, and export it in dwg there. and check.

it should tell us if it is indeed the dwg translator in SU23 that is at fault.

troubleshooting is like a puzzle. I like puzzles.

If you use the text label tool to mark the coordinates of the holes, with units precision turned up to max, you will see that some of the holes are not exactly on the surface of the plate. Although the differences are small, sometimes such tiny discrepancies can confuse SketchUp’s handling of faces and cause it to produce triangles.

1 Like

The edges @sWilliams highlighted indicate you are exporting with faces. Try exporting without faces. Go to Options in the Export window.

Trouble is I cant open the SU file in 2019 as it beens created in 2023. So I could import the DWG into 2019 and then export it again but surely it’s already got the issue attached to it?

and I presume you mean, send it to cnc person to check, as for me it does the same thing in which ever version of software and on both laptops. But that makes me think what I see as the problem when exploding isn’t actually the problem… if that makes sense?


open in SU 2023.

menu, save as, and here you can ask SU 2019.

also, Slbaumgartner found the issue. some holes are not completely level.

the hole issue would make sense, but he also cant open files which are just panels without any holes … literally just a 18mm thick rectangle

how would I fix the hole issue?

Erase them and try redrawing them carefully.

Edit: Scaling up by 1000, doing the fix at that size, then scaling back down before export should help.

1 Like

hahaha no there are two issues. the hole is a hole issue. as slbaumgartner just posted, redo them, it should be ok.

but us, we’re talking about opening a SU23 file in SU19.
if you open your file in sketchup 2023, menu “file/save as” you’ll be able to save your file as sketchup 2019. since 2021 you can open any file, no problem, but in 2020 and before, you had to do that.

anyway, it’s all moot, now that Steve found the hole issue.

I draw so many holes and this has never been an issue before… Its also an issue with files without holes?

Also he is opening them in autocad and in solidworks, (he doesnt open in sketchup)

I have saved the file in 2019, and exported it as a dwg on both old and new laptops and have sent to him… he will try and open them tomorrow so will see if that makes a difference… I really think its a 2023 software issue, but no idea how to fix

The entire top of the plate has got a small non-planar condition. Have a look at the z coordinates of the upper corners vs the lower corners in the screenshot below. This suggests to me that you haven’t been adequately careful either using inferences or entering exact values in measurements. The holes are interacting with this non-planar face during export. Yes, the discrepancies are tiny, but as I mentioned, sometimes even tiny errors such as these can cause SketchUp to triangulate what should be a single face.

Thanks again everyone for helping by the way!

I see what your saying but, I draw to the mm and always have done, I’m not sure how I can be more accurate / how I have been more accurate in the past when this issue wasnt happening. I’ve not changed anything about the way I draw… The issue is across 30 panels on the new software. I can’t have drawn them differently / less accurate than the 600+ panels i drew before the issue started.

unless im not following you correctly?