Problem in Drawing When Importing DWG to SketchUp

Hi All,
When I import a 3d dwg file to SketchUp, the whole drawing and each surfaces shows as a drawing, so when I explode them all the edges all disappear and the surface of the drawing turns into one whole surface. If I want to edit each faces individually I will need to redraw all the edges.
Because of this problem, I tried exploding the CAD drawing before exporting into dwg and when I import that into sketchup only the lines show…
Can anyone please help with this?

Maybe the edges are smoothened or hidden, can you share the file, the dwg and the skp if it’s possible

I’m not really sure but here are the files.
Test Export 2.dwg (4.4 MB)
Test Export.skp (1.2 MB)

Try to show hidden edges and right click on smooth edges

1 Like

Your “Test Export.skp” seems to be just fine.

  • turn on ‘View Hidden Geometry’
  • each wall face, the top faces and bottom faces are grouped individually with hidden diagonals in them to triangulate those faces. (see* below)
  • enter each of these groups or components to the lowest level of basic geometry and delete the diagonal. (these faces are coplanar so the face per wall should remain)

(*) When importing the dwg there should be an option to avoid triangulation so you won’t end up with these diagonals (see options in import window).


Ohh right thank you. I haven’t thought about the smooth edges. It worked with the edges thank you :smile:

I tried setting the ‘Merge coplanar faces’ to avoid the triangles before importing again and it worked. thank you :+1:


I reported the issue a while ago, about importing autocad regions. In your dwg you have 20 regions that get imported. Did not seem to interest anyone at the time :