Help - Object faces break down into triangles 2022

I’ve been reading older topics but cannot fix this issue. Sketch Up Pro '21

I have imported a CAD file but some areas are problematic when trying to form faces. The face breaks itself down into a multitude of little triangles with no edges. I tried deleting them and redrawing, some work some don’t. I have the hidden geometry on too and still can’t figure it out. On top of that some of the lines look as it they have gaps.

Can someone please advice me how to fix it?

What I guess we are seeing is screen artifacts caused by very large extents of the model. Did you use the “Preserve original coordinates” option when importing? Can you post the model?

I haven’t used preserve original coordinates for this one as I had issues importing it at first. Is there a way to fix it at this stage still? I will attach the model here, thank you!
NP.skp (7.2 MB)

I was wrong. What we are dealing with is the tiny face issue. You seem to have used Millimeters as your import unit instead of Meters - a street I checked is 7 mm wide.

First thought was those faces were not flat and needed to be flattened.
Second thought after opening the file the large distance from the origin point.

But like Anssi mentioned the scale was off since the distance to the origin point was only 3 meters.
(total lenght of the map was about 1 meter :wink: )

So i started rescaling the model since that should be easy.

While rescaling the model i also noticed the huge amount of tags/layers that are/were turned off. So i first grouped all visible and created a scene with the current tags visible. Then i turned on those hidden tags and rescaled everything 1000x. Then i noticed there were a lot of (those hidden) edges that went through those faces you were working on so I guess those faces were intersecting these hidden edges and coused havoc.
If you don’t need those edges from those hidden tags, i would suggest deleting them so they can not interfer.

Also noticed there are a lot of open edges (selected in blue below) that could couse havoc while trying to make faces from cad drawings. So in case you try to close a face but it does not, there might be an open edge sticking inside that area/face keeping you from ’ closing/creating’ that face.

At least those are my known issues with cad files and sketchup, hope it may help you fix your problem.

Do you have an original version that you did not delete any lines from (or draw lines on, or explode groups/components in), or move anything?

Did you make the group ending in “-2D”?

It seems like a line was deleted that was tagged, “Newport Road…”.

There isn’t much organization in this model. There are 37,000 plus components, and over 180 tags. I made groups of the components, ‘like with like’, for most of the components. I made about 50 groups.

In the image above you can see that over 19,000 components are selected. It’s not ‘user friendly’ to scroll through all of that.

Here are maybe 20 of those groups.

As others have pointed out, the scale is off. It also seems that parts of the model may have been moved. If the grouped components (highlighted) are in their correct relative positions, are they needed?

I think you need to start over with the original. First group all geometry, even if it is just, ‘like with like’. Turn off their visibility as you go. Is anything left? Can anything be deleted as unnecessary? Once you are organized it will be easier to avoid accidentally merging geometry.

You may want to get organized by making groups and categories that are useful to you. Make tag folders and use names that are relevant to your objectives.

Once you’re organized, then select where you want to draw (in a group. component, or something new).

1 Like

Thank you all for the advice. I am aware the model is not to scale. I tend to work on it as it is, make the faces then scale up so the software works smoother.
I’ve asked for the CAD file to be cleaned from the design team before I imported it in SketchUp twice. All the messy layers and groups from the CAD file. The issue I have is that I don’t have access to AutoCAD to sort the file myself. It’s the first time I see issues like this in a model - the tiny face issue.

I’ve tried uploading here the initial imported version of this model without any lines being deleted and with “Preserve original coordinates” option but the file is too large. Is there a way to upload bigger files?

Using Meters as the unit when importing would probably help with making the faces. Now you are stumbling to SketchUp limitations on forming faces with submillimeter sides.

1 Like

I use QCAD-Pro for this sort of thing. Sure, you pay for it, but not much.

1 Like

Maybe a OneDrive, DropBox, or Google Drive link would work for sharing.

I’d take the advice others have given you here. You probably can get the model into a usable state. But try to organize it in a way that makes it easier to work with.