Object faces break down into triangles

triangulation

#1

I’m running Sketchup 2017 Make on Windows 10.

Lately I’ve been working with some drawings and have wanted to use an object duplicated in several positions around the model, rotated to the appropriate orientation.

Unfortunately after rotation some of the faces seem to have … degenerated.

The face breaks itself down into a multitude of little triangles with no edges, and won’t recompose itself even if I break off the detail lines and redraw the face. You can see some of it in the lower copy on the attached image, I’ve reversed a few of the faces to highlight the issue.

I’ve also attached a copy of the .skp file this image was generated from for examination. Any ideas what causes this? Any way to undo it, make it go back to normal behavior? Thanks!

Widget.skp (1.4 MB)


#2

Hi,

I’m afraid I don’t have too much time to really get into this one.

But, I think what’s close to the root of the problem here can be wrapped up into a lesson on basic tidiness while modeling.

Try turning ON the setting for >View >Hidden Geometry. . . and take a look at all the extraneous edges laying around throughout the modeling space.

Secondly, I think this a good example for why it’s always a nice idea to group your geometry together at strategic moments during the modeling session. You get to decide for yourself, and your own work flow when these moments should happen. . . But I think in this case there’s a good reason to have created groups for your core model prior to all the gymnastics that you’ve run it through.

In doing so, there’s just a lot less chance of leaving element of the model behind.

My guess is that incomplete selection of the ‘entire’ model, prior to copy/pasting… and moving/rotating, caused the otherwise flat planes to be pulled out of their pristine state. . . hence the subtle triangulation which you’re seeing.

It’s a nice shape, and I think overall you’ve done a good job with it all. But, a little more attention to process, before going into all of the advanced modeling rotations will serve you well.

Getting back to your original shape could possible happen with the undo history, but after too many saves those options get lost, unfortunately.

Take Care,

Jim


I’ll come back and fine tune my comments tomorrow, I have a few things I’d like to also mention, as potential tips. unfortunately, for now, I have to try and force at least a couple of hours of sleep upon myself.


#3

Switch on View > Hidden Geometry
Your model is full of unused/unwanted hidden lines floating in space.


Then the weird surface is split into triangles and some facets are reversed.
Unfortunately that ‘face-plane’ is twisted slightly so you cannot delete the unwanted triangulating lines, as the faces they support will erase too.
You need to redo it so it’s in one piece.


#4

Here’s a quick version of how to clean it up with just standard tools.
The two bits you can’t see are me hitting ‘Copy’ of the half before scaling, then ‘Paste in Place.’ The result is a solid clean component, and a flipped copy of the same component.


#5

Thanks for the advice, I’ll take a closer look at the model and see
what I can do with it. I hadn’t even considered hidden geometry like
this. It’s certainly not anything I drew…