What's wrong with this specific spot?


#1

I’ve been having problems creating a face in one particular spot in my model.
It’s really weird because right next to it i have a perfect face. I have tried to copy that one over but then it glitches and “splits” the face. I tried extruding form the good face, same thing happened. I redrew things around it, checked everything was on an axis… I’m getting pretty upset.

I have attached a picture of one of my attempts of getting around it… notice that I haven’t even drawn a closed shape and it’s making a face section already.
I have to give this is in two days. HELP!!!


#2

It’s hard to tell onyl from this image (which face do you mean?), some thoughts:

  • The face in the front has an edge parallel to the red axis at the bottom and a blsck one at the top, there will be not a single face…

  • There are a lot of hidden lines (or are theyy behind other geometry?

  • Have you separated the geometry with groups and/or components?

  • Did you use Layers (and moves loose geometry to other layers than Layer0)?

  • Does switching to perspective view have an influence on your problem? If so, clipping can be the problem)


#3

Yes, the roof on this house is on a slant. The tops on my walls aren’t parallel to the axis, this picture shows me trying to make it simply on the axis and still having this issue. I didn’t even make a full shape! I drew 2 lines and then the “triangle” face shows up.


#4

That sounds like a layering issue. See the following:

Does SketchUp support layers?

-Gully


#5

Just tried making everything the same layer to avoid issues (my walls were 2 different layers)

but still, same thing happened.


#6

As @Cotty said, it’s hard to tell what’s going on without looking at the model.

-Gully


#7

If you can upload your model here, we can give you more exact advice. Working from just an image, it is often not possible to do more than guess. Frequently there are very small misalignments that cause this kind of error but are impossible to see in an image.


#8

It can be said that the color by axis feature is nearly useless for detecting small alignment errors.
Raise your precision and check things in that area with the tape and protractor.

Shep


#9

that’s the thing, i erased multiple walls and line and the likes to realign it all. It’s very very frustrating.

Just tried to upload it, it’s too big apparently.

I only put the colour my axis feature on for this.


#10

what’s also strange is that I drew 1 line, and when I select it, it’s now 2. There’s nothing there though…


#11

There! managed to upload it
KBELAIR_CaseStudy.skp (405.2 KB)


#12

Please upload your model to the 3DWarehouse, DropBox, or whatever your favorite file-sharing site and provide a link here. That’s how we work around the upload file size limit.


#13

You have a hidden edge affecting the specific place you show. Either unhide all or show hidden geometry:


#14

Wow! I’m actually mad that that’s all that was causing my issues.

Thanks for you help everyone :slight_smile:


#15

You also still have primitive geometry on the roof layer. It should be on layer0 to avoid confusing you later!


#16

You also need to fix all those reversed faces and get all the geometry onto Layer 0.

I’m too slow.


#17

yes, i was working on the roof while i waited for responses. i am going to make a component. anyways. thanks


#18

Nobody would dare call you slow, Dave!


#19

hahah! aw, i appreciate it anyways!


#20

:blush:

My wife might.