Extra Faces created...sometimes

Hi,
Here comes a problem I face when importing a dxf model (created in DELFTship).
Some faces do not get created (it is frustrating, but ok), so I try to make them by hand drawing an extra edge in the triangle.

When I draw an edge from the base of the triangle to its corner there are two faces created in each section, but when I do it in the opposite direction - only one (as it should be!), see video please.

Sorry, but for some reason the pop-up menu does not appear in the video, but what essentially happens is that I right-click on a face and do Erase. In the first part I have to do it twice on each face, in the second one - only once.

The same extra faces pop up if I use plugins (Make Face, or Face Creator).

An extract from a bigger model is attached.extra_faces.skp (343.8 KB)

Many thanks in advance for any suggestions.

Is the beam at that point in the hull really supposed to be about 19mm wide? Maybe you need to be selecting different units when you import the dxf file? I don’t know how big this thing is supposed to be, though.

As for the “extra faces”, they aren’t really extra faces. As you can see, the vertices are not all on the same plane. I’ve laid the thing down so the top edge is on the ground plane. If this thing was flat. The vertices would all have the same Z-values.

There was an amazing amount of geometry in this model. I expect all laying on top of each other. I fixed the incorrect tag usage…
Screenshot - 5_2_2021 , 11_06_42 AM

…and purged unused stuff.
Screenshot - 5_2_2021 , 11_19_15 AM

Then I flattened the geometry…

And removed the now unneeded edges.


Notice there’s almost a 96% file size reduction after cleaning the model.
extra_faces flattened.skp (14.4 KB)

1 Like

Dear Dave,
Thank you very much for your very detailed study of my model.
I am not sure though that I understand how it is related to the problem.

Everything that happens in the video is related to just three edges, a triangle


All the other elements of the model are just to provide some context.

What I do is just adding another edge in the triangle made of the three vertices marked in red.


And as you can understand, any three vertices are always in the same plane. If I start in one vertex and go to the middle point of the opposite edge the result is just two faces, if I start from the middle point and draw to the vertex the result is 4 faces. That is clearly a strange behaviour, isn’t it?.

PS
the complicated geometry must be some sort of a bug. maybe after I deleted the rest of the model.
For me it shows just 24 entities. I havent counted but seems about right.

PPS
and no, the model should not be flattened!

Why would you do that to fill in the face? Why not just trace along the edge of the triangle? That’s the normal way to heal a missing face.

the extra faces you are getting appear to be due to the tiny size of the model and hitting some built in tolerances. If you scale the model up that doesn’t happen.

The huge number of edges and faces listed in the Default Tag geometry comes from the hull component that you deleted from the model space but didn’t purge.

Ok. Excuse me. I had no way of knowing that.

Some of this discussion may be relevant:

Short version is that a coplanar face need not be surrounded by coplanar edges. I think some of the connected faces are not quite coplanar, and at one point in your featured triangle there are multiple line endings that are almost in the same location. Drawing a line away from there will only connect to one of the line endings. Drawing a line that ends there will connect to all of the nearby line endpoints, and have the effect of creating one face per line ending that isn’t quite identical to the other ones.

In that discussion sWilliams made an extension, that lets you make a set of selected edges and faces really be coplanar. I tried the extension on your model, and it seems to make things work, without having to flatten the geometry onto the ground.

Here is that extension, it appears as Flatten to Calculated Plane, in the Extensions menu.

sw_flatten_to_calculated_plane.rbz

Well, that’s a different question, but I must confess I dont know what you mean by ‘tracing along’ :persevere:

I am not sure that sounds as an explanation to me… there appear EXTRA faces due to small size of the model? there appear extra face when you draw an edge in one direction, and does not in the opposite? doesnt sound related to small size of the model to me… if there were no face created then it would make sense.

UPD
but you are right, it disappear after scaling. To me it seems to be a SketchUp bug.

you need to purge after deleting? sorry for being a newbie, but how do you do it? =)

Regards,

Simply draw along an existing edge.

Yes. Components, materials, and styles remain in the file even if they aren’t used in the model space until you purge them. This is a handy thing because you don’t lose objects or materials simply because you’ve deleted them from the model space. Very handy if you delete something by mistake. But it you really don’t want the thing, you should purge it to prevent file bloat. Model Info>Statistics>Purge Unused will get rid of all of them.

1 Like

also an option indeed, and actually I was doing this way when I first faced the problem, and then I started to draw an additional edge in attempt to avoid `extra faces’.

It is indeed, I will start using it. Although it is strange that thousands of the deleted faces and edges (apparently all of the same style and material) left some traces in the file after deleting.

Thanks for you time and help.
I do believe that we shall report my problem as a bug =)

You should read my reply. It’s a known issue, caused by the difference between what is considered a coplanar face, and what is a coplanar edges. They have different tolerances, and this is one of the ways the problem can show.

Sorry for missing it first time, was busy answering Dave.

I am not sure my simptoms are similar.
In my case in both directions there are created faces for two new triangles (parts of the old one created by the new edge), but in one case there seems to be more faces which actually disappear when you scale the model.

It can be related, but in any case, it looks like a bug.

Regards,

I suspect this has to do with the import file. Here I’ve manually inserted guide points at the coordinates from your file after I had moved your geometry close to the origin.

Then I connected the points. The blue edges were required to complete the faces that are shown in green in your file because those points don’t lie on the same plane.

There are only the 13 expected faces with no overlapping faces as in your model.