Everything takes hours


#1

Will somebody please tell me why I have to do this Sick.skp (39.5 KB)
To get this. Why will it not just fill in a completed borderSick2.skp (32.7 KB)


#2

How are you trying to draw it? Clearly something is missing in your process. Look at the Y-values in the attached. You aren’t keeping your edges on the same plane.

Try drawing it on a larger rectangle. That’ll make it easier to keep the edges coplanar. that will make it so you don’t have to draw triangles to get faces and it’ll save you hours of drawing. That entire shape ought to take no more than 5 or 6 minutes to draw from scratch. Probably less.


#3

If you look you can see the edge of the rectangle that I drew it on before I deleted it. I just don’t get it. If you ever subtract one solid from another this misalignment happens all of the time. I wish I had started with another program. 2 years at this it’s just hopeless.


#4

I don’t know how you could have a solid since this is ostensibly a flat shape.

It is possible to do this without the misalignment you’ve got in your example. I was going to offer to show you but it sounds like you’ve already given up.


#5

@DerekBr0wn
I agree with Dave, this should be quite simple but the face is not coplanar to me.
If you have to draw lines like you have to create the face, that’s the big clue.


#6

Sorry I was not referring to this model. I do a lot of combining with solids. It often creates short edges and creates hidden vertexes. This is a product fault and should not be advertised if it cannot do it.

I would still be interested in your fix.

Best regards
Derek


#7

No. It’s not a product fault

The one you drew on the rectangular face worked fine. There’s no misalignment. Apparently you can make that work correctly.


#8

Dave R Not Quite sure what you mean. I thought you said that the y axis was misaligned? I can extrude this model. My question was, why do I have to create the triangles everywhere just to get a plane. I did draw the whole thing on a plain. But my claim is not that this model does not work only that it took so long. I have shown examples on this forum where all I have done is create two perfect solid 3D images and subtracted one from the other and it creates short edges and additional vertices. This is the product fault that I was describing. It’s an absolute nightmare especially when subtracting or joining cylinders at angles. It really cannot do it. I have shown examples and the only answer was to scale up and down, dramatically. but still creates hidden vertices. I cannot be the only user that has this problem. Actually in one post other users posted examples of similar problems


#9

They are in one of the files you attached. In the other they aren’t.

Do you remember your very basic geometry? In order to get a face, ALL points must lie on the same plane. Any three points can be used to define a plane. Four or more points must always be on the same plane to get a face. In your model from which I made the screen shot, the points I marked have different Y-values. They are not all on the same plane. You get triangular faces when you connect them as you did. That does not create a single large face as in your other file.

I’m telling you it shouldn’t take that long. This is real time. Done in one take. No speeding up the video, no cuts to fix things.

I’m not sure what you expect would happen. How could you not get shorter segments and additional vertices? You must have known for almost two years that SketchUp represents curved surfaces with a collection of flat faces.

SketchUp can do it and create solids that are 3D printable from even more complex shapes. In all of the following examples, all of the components are solid and printable. I used Trim from the Solid Tools set in at least one case in all of these.

The knurled knobs are 1/2 in. in diameter.

Bracket to fit on the handlebars of a bike.


The 3D printable version of these finials have an overall height of 3 inches.


Every component in the table, including the legs, are solid. The model could be scaled down to fit a 3D printer.

As with any tool, you must learn to use it correctly. I’m getting the impression, though, that you want to look for a different tool.


#10

It took me 4 mins, I did it the long way round without copying anything using guides:
All faces there no messing.


#11

FYI, deletion of coplanar edges deleted much of you model including the head lights , they have small gaps. The basic poloygon shape became selectable as expected… I’ll leave to your own conclusion what the issue is. Spending the amount of time you did would probably have me looking in the mirror. I have other suggestion but will probably not help now.


#12

I have spent a lot of time blaming myself. I understand that there is something wrong with the model But I promise you all I did was draw some circles added an arc to them and deleted what was not needed. My question therefore is where did the gaps come from. I have been doing this for a long time. I operate CNC machines any gap in any part of the drawing to be machined and it will not work. I do understand it. My question would be how does it leave gaps. I zoom into stuff so close that it disappears from view. In any case this does not answer the solid object problem which causes me to start all over many many times. I really do not think I should have to repair errors CAUSED by Sketchup.


#13

DaveR For some reason I am not getting responses to my questions on time. My last response was posted before your work was displayed on my screen. I have just seen the video you ported for the first time. It is now 12.30 AM in UK so please do not think I am ungrateful. It just was not there until 30 minutes ago. Having watched it I can confirm that that is almost exactly how I constructed it myself. I am still no wiser as to how these gaps (in my version) are created.

Also when talking about subtracting or joining solids. I am aware that extra vertices are created. That’s not the issue it is when new vertices are created that should not be there such as on a previously none vertex flat surface. The extra vertices are not the issue it is the fact that when they are created you can no longer extrude that surface as one face


#14

In general, when making a 2D outline that I want to be planar, I get the best results by turning on parallel projection and orienting the view to look straight down on the x/y plane (red/green). When done, I simply move and/or rotate the result into place. This seems to always produce a depth coordinate that is exactly zero, which insures that all of the geometry is co-planar.


#15

Jimhami42

That’s useful I will try that

Derek


#16

Look for the inference cues that appear at the cursor to ensure your are creating everything on the same plane. That may mean pausing a bit to ensure they appear.


#17

Are they the red squares that show instead of green dots?


#18

https://1drv.ms/i/s!AhY4t4UjuOcbzxPg4j8k8TzocjeK shows how little mistakes can be. Without plugins like Fredos Edge Inspector it can take hours to find such tiny things.
You should not upload the corrected files. So it is impossible to say what You made (possibly) wrong.

BTW: “Edge Inspector” does not find the 16mm lines - they are possibly to long.


#19

No. You don’t need any plugins to find little mistakes. Just use the tools provided in SketchUp.


#20

@miller
"BTW: grad runs a thread “everything takes hours”, where once again is silent about all aids such as Workplane, Flatten to Plane etc."

I took the above comment from “quick way to distribute holes” thread.

I don’t see the point in a plugin suggestion to fix what is simply incorrect practise. The operator needs to learn how to use the basic tools correctly in the first place. Cheating with a plugin to clean up a mess will not help in the long run.