Erratic behaviour of edge intersect in simple geometry


#1

There have been a few threads relating to this issue already but it’s not been solved or flagged as a bug as far as I can see.
Try this simple drawing and see if you get the same strange faces and edges that I do.
The face is around 3m so not either too big or too small.
The face is flat and there is no hidden geometry or anything else in the model.
Even a triple click or fence select and second intersect doesn’t fix it for me.


Face Won't Intersect With Edges
Is it a bug? not possible to delete a hole touching a face
Is this considered normal?
SketchUp Pro 2018 is not recognizing the “closed” polygons as distinct boundaries
#2

I can reproduce that here.
(Being very pricise when drawing)
No intersecting helps here neigther.
2015Pro


#3

I can reproduce it too. (Sometimes with different errors, but always with errors)


#4

Thankyou Gentlemen, it’s nice to know it isn’t just me.

Yes @cotty it does vary, sometimes the diamond face in the middle even becomes a hole.
If you are less accurate and don’t inference the points it seems to cut properly, which is very odd.
I get the same result in 15,14 and 13 although in 13 it can easily be corrected by 'Generate Faces’
I don’t have a PC here with SU8 to test, would be interested to know if it does it there too.


#5

buggy, I agree

I think the work around would be delete all the faces, (plus some unexpected extra ones?).select all,.then place a new face over the lot then intersect face with selection.

I makes one feel sorry for the scolding some got about their inaccurate drawings


#6

Can confirm issue in SU 8 too.

And also the different outcomes.
(Glad this is brought up! When I started learning SU, thougth it was me doing wrong! :relieved: )


#7

Your workaround makes sense but it doesn’t actually always work. This specific bunch of lines causes all sorts of weird issues no matter how you try to make them split the face. Different variations will produce different results, most of them odd.

And I agree very much on the whole telling people they must have done it wrong. This is a good example of how each situation can highlight it’s own problems, and how catching bugs is a never ending problem.


#8

If you follow the sketchup rules, they tell us not to over lap lines when drawing surfaces. that is bad practice and leads to this sort of thing. same goes for push pull. never push a surface into itself using CRL key, it causes surfaces problems.
So learn a different approach or method and watch the sketchup basic tutorials again
Daniel

www.wardrobewalkin.com


#9

Maybe I’ve to review some of my own beginner videos… thanks for the tip.


#10

Those sound like good rules, which I haven’t seen. Would you be so kind as to provide a link to where they are documented in case I need to refer to them?

-Gully


#11

I’ll point out that the shape above can be drawn without the errors by using more conservative (for lack of a better term) methods. As always there’s more than one way to do things.

Shep


#12

Ok No overlaps!

The point I’m getting at is that at certain times a simple line does not cut a face even when drawn correctly on the face.
This is not a feature or a rule or something that should need a work around. It is a tiny flaw in the program that is worth bringing to the developers attention.


#13

@Box

Thanks for bringing this up. I tried modeling this the way you first described and got the same result also. I won’t be so frustrated any more when a face needs to be redrawn to register correctly.


#14

I think this is another manifestation of the same problem as discussed in this topic, where it arises in a different way:

In both cases there is erratic behavior of whether or not Edges that by all analysis are on a Face do or do not cut that Face. Seems like a hole (pun intended) lurking deep in the logic somewhere.


#15

Yes, I very nearly posted it to that thread.


#16

Shall we put all our bugs in one basket? Did I say bugs? I meant features.

Shep


#17

On the tests that did not intersect correctly, try selecting all > r-click and Intersect.

Until SU7, edges did not auto break when things intersected and we would have to intersect. It took awhile to get used to as many people developed workflows that took advantage of the lack of auto intersecting. Smustard developed a plugin to revert to the pre-SU7 functionality for those people.

I’ve noticed BreakEdges doesn’t work 100% “as expected” since it was added, and selecting and intersecting was still needed sometimes. But when trying to duplicate the OP sample, I found if I paused a bit to be sure the inference engine kicked it, breakedges could work as expected.


#18

Under the hood, faces in SU are triangulated. One of the special things about SU, is that co-planar faces can appear as a single face. You see the triangulation when manipulating geometry as in folding. In the animation, it did not look like all the ziggy-zag edges where planar as shown by the hidden geometry.


#19

I’m not really sure how long you want me to pause to wait for the inference to kick in, usually when the tool tip tells you something is on face etc should be enough.
As for select all and intersect, sure I can do that, but I already pointed out that doesn’t always fix it.
Here it is again, and as you can see is easily reproducible. The edges are broken because you can select them individually, but they are still connected.
It may not behave the same way on your system, perhaps it is a graphic card issue or some sort of system setup, but it does happen, is reproducible and it’s not just on my computer.
It’s not bad modelling, it’s a flaw in the software, which is why it is worth pointing out and not glossing over. It is the very definition of a Bug.


#20

Here’s another look. This “feature” was covered in a different thread with only two simple planes. In this view I add a hexagon to show how the problem is amplified.

All we want is to make a great application better.

Shep