Faces duplicate when splitting a face

I have noticed over the past few releases of SU that if you have a single face (say a simple rectangular face with four edges drawn in any orthagonal orientation) that if you draw a line from one edge to the opposite edge in an effort to divide the single face into two separate faces that SU randomly decides to create multiple duplicate faces on top of each other on either side of the now split rectangular face. In some cases there could be as many a five or more faces on top of each other where in earlier releases of SU when drawing a single line from one edge to another edge to split the face into two distinct faces was done clean and easy without any complication like the one that is present now. The only workaround I have found is that you cannot simply draw a line to split a face anymore like you have been able to do since SU was invented, instead now you can only copy similar edges adjacent to the location you want to split or you can draw a line off to the side in the orentation you desire and then copy it to the location where the split is needed in order to split the face without SU automatically creating a duplicate face(s) on top of each other.

If anyone has an idea how this can be corrected permanently so that SU does not create duplicate faces that would be greatly appreciated, as the traditional method of spliting faces that has been in place since SU was first created now doesn’t seem to work properly anymore.

.

I don’t recall any others posts reporting this issue, so it may be an extension creating additional faces…

what extensions do you have running?

can you add a model where this happens…

john

In addition to John’s reply please update your profile to accurately reflect the version of SU that you are using . SU Make was discontinued in 2017 and has not been updated since.

I think I’ve seen this on some rare occasion when a face isn’t fully planar but kind of almost.

I am not using any plug in to draw the geometry as I described. I am using native traditional SU tools (Line) to split a face into two parts. I currently use SketchUp 2019 Pro. This problem duplicates on multiple workstations so it is not isolated to a single file or a single workstation. I am unable to share any original files as we have signed NDA’s in place that prevents me from sharing the model with anyone outside of the NDA. I have however created a new file and copy and pasted some of the geometry to illustrate the issue.

SU Modeling Issue.skp (183 KB)

first response is that I have seen this when people try to ‘model’ in any ‘iso’ view…

general advice is to model in perspective, select and export in Parallel Projection only when needed…

john

That sounds nice in theory but often times you are unable to zoom in close enough to see the model before it starts to clip away so the only alternative is to zoom out far away then go back to ISO and then you can zoom in as close as you could ever need to. But not really the issue I’m here seeking a solution for as SU is duplicating surfaces when splitting a single surface through the use of their native line tool. I did model this in perspective and this issue still occurs. The file I attached was a newly created file that was in ISO mode by default and I merely pasted the copied geometry from the original model where it was originally created in Perspective mode and then duplicated the issue again in this new fresh file. The issue is unrelated to perspective mode or ISO mode as it occurs in both regardless.

In your models go to Model Info/Units and turn off length snapping.
If you look at the coordinates of the two points where you added the line you will see that they aren’t coplanar. This is usually caused by having length snapping on which forces the endpoints to go where you don’t want them to be.

1 Like

Clipping tends to be more of a problem with Parallel Projection than with Perspective.

It can be both. In perspective the mouse wheel moves the camera back and forth; in parallel projection it changes what “height” the camera has. If you are inside of a building, switch to parallel and “zoom out” (change the image height but with the camera position being kept) you’ll see the house cut in two. On the other hand, if you want to see a small detail you can switch to parallel as it allows you to upsize that view, without actually taking the camera closer to it. The clipping in perspective is a bit weirder as it cuts of geometry also in front of the camera, and this distance depends on the physical size of the model.

Yes it can but I see it more in models I get from people in which they are using Parallel Projection.

I tried this and the problem persists…

I’m not saying it will fix current issues, just that it will make better models in the future.

Ahh… Well thanks for the tip

Turn on hidden geometry and look at the top ‘flat’ planes of your model. If they are flat there should be no hidden edges showing.

Everything is clean and flat.

Really, how come I see this then?

1 Like

Interesting. I saw a lot of hidden edges, but deleting them did not lead to lost faces so they were spurious artifacts of previous editing.