Extensions not working

Sorry for what might be a simple question, but I have installed a few extensions in my SU model, they appear as Enabled in the Extensions Manager, but I cannot get them to function. For example, I have SandBox installed, but I do not have a SandBox tool bar visible, nor is this, (or any of the others), listed in the Extensions drop down menu. I am using a Mac and SUPro Version 22.0.353
Many thanks.
Chris

Can you confirm which version of SketchUp you are using? I think there is a known issue on these lines in 2022, but your profile says you’re on 2021.

Sandbox isn’t in the Extensions menu, look to see if it’s in the Tools menu.

A lot of extensions are not found in the extension drop down menu.
A lot of them are in the tools menu, some only ad something to the right click menu.

What are the known issues with Sketchup 2022 and extensions?

Thanks for more information.

I can’t find the exact details, but I think that with Advanced Camera Tools being removed from 2022, installing the extension from Extension Warehouse could lead to problems. Whatever the case was, it should be fixed in the next update. Can’t say when that will be!

Hello Colin. I am pretty sure that I am using Pro version 2022. I have made sure that there aren’t any updates to the version that I am using.
I have looked in the Tools menu and none of the extensions are listed there. I would have thought that the SandBox tool would appear in the tools, given that it must be a fairly ubiquitous plugin.
Screenshot 2022-07-10 at 09.47.27


Did you look at View > Tool Palettes > Sandbox
and Draw > Sandbox ?

Nothing in there.

One thing that looks odd is that you have the file names and generic icons. I matched what you have, and still sandbox works, and the list looks like this:

Are you running SketchUp from the downloaded file or have you installed it properly?

“… installed it properly?”
I’ve installed it as Trimble allows me to install it. If that’s not properly, I am unsure what I have done wrong.

I did test running from the disk image window, which is something we fixed a few versions ago. Took a long time to verify and open, but Sandbox and the other extensions still looked ok.

Install properly means you dragged the SketchUp 2022 folder from the disk image window into your Applications folder, eject the disk image, and run from inside the Applications/SketchUp 2022 folder. We fixed issues about that a while ago, where SketchUp running from anywhere except Applications/SketchUp 2022/SketchUp, could lead to crashes. It’s still best to run from the Applications/SketchUp 2022 folder.

One thing to watch for is if you have icons in the Dock that may be pointing to other places. After running SketchUp from Applications/SketchUp 2022, look to see if there are other SketchUp 2022 icons in the Dock, that are not currently open. Would be worth removing those from the Dock.

You can tell whether it’s a 2022 icon or a 2021 icon, the 2021 version was a lot bigger looking.

I have only one SU icon in my dock. I have tried opening SU 2022 from the Applications folder and I get the same result. Perhaps I should try reinstalling the application?

One useful trick with the Dock is that you can Command-click on an icon, and you are taken to where the application is. If it is in Applications/SketchUp 2022, and the modified date is Feb 22 2022, it’s likely to be ok.

The support files might be messed up, and those are not recreated when you reinstall the app. To test if something may be wrong there, close SketchUp, and switch to Finder, then from the Go menu choose Go to Folder…

Copy and paste this text into the dialog you are shown:

~/Library/Application Support/

Look in the Application Support folder for the SketchUp 2022 folder. Rename that to be something else, SketchUp 2022 Old for example.

Reopen SketchUp 2022. You will have to agree to the terms and conditions again, and you will only get the standard three extensions. See if Extension Manager shows normal icons and names, and if Sandbox is in the Tools menu.

If it looks better, might be safer to reinstall the extensions you want from Extension Warehouse, and to redo any keyboard shortcuts you had changed. For custom components and materials, I can tell you how to copy those across. But first see how it looks after the support folder refresh.

I am now in a spiralling vortex of pain - having renamed the App Support folder, I cannot now open SketchUp as I am being told that I have exceeded the allowed number of activiations. I have tried Deauthorising devices and get confirmation that this has happened, but if I log out and in again, I get stuck in the vortex off disappointment. This shouldn’t be this hard. I do not have SU installed on any other devices.

Sorry about that, it does indirectly help me with an unrelated issue.

After deauthorizing and logging back in again, before you log out, what was the state of your extensions?

Colin. I am so grateful for your responses.
Very oddly, after lots of attempts to deauthorise myself, SU suddenly started working again.
When I opened my SU model, the extensions were exactly as they were, unworkable. I tried to reinstall the Sandbox extension via the menu in SU, but no this did not result in an improvement. So, I decided to try another approach and found a link to the Extensions Warehouse (rather than use the menu in SU) and downloaded the extensions that I needed. I saved these .rbz files locally and installed them by using Extension manager and hey presto, they work and the icons appear correctly in the Extensions Manager box.
This is a little worrying, but at least I have found a solution.
Thank you for your assistance and forebearance.

No - there should be no problems installing ACT. It was only removed from being a default extension pre-installed.

The generic icons means that the connection to Extension Warehouse must have failed. This is usually resolved by signing in again.

1 Like

I did find out that the issue I was thinking of was Windows only anyway, and wouldn’t have caused a problem on Mac.

Interesting about the generic icons thing. Do you have any new ideas as to why Sandbox isn’t showing up?